summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-09-10 10:43:05 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-09-10 10:43:05 +0200
commit749d0e2ee05f7e38689f193eb28764e8ca7d388c (patch)
treeb6cccea0c6219696e461f10758dbb970e79456cc /gnu/packages/geo.scm
parent92d04bcab34ef7145bd18e5a7d242e38d01d3922 (diff)
downloadguix-patches-749d0e2ee05f7e38689f193eb28764e8ca7d388c.tar
guix-patches-749d0e2ee05f7e38689f193eb28764e8ca7d388c.tar.gz
gnu: qmapshack: Remove obsolete phase.
QTWEBENGINEPROCESS_PATH is now set by the 'qt-wrap' phase. * gnu/packages/geo.scm (qmapshack)[arguments]: Remove 'wrap' phase.
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm17
1 files changed, 1 insertions, 16 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 7010d24ed5..0e8872a3c9 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1715,22 +1715,7 @@ using the dataset of topographical information collected by
;; of QMapShack, but they are not applied by default, for
;; some reason...
(invoke "patch" "-p1" "-i" "FindPROJ4.patch")
- (invoke "patch" "-p1" "-i" "FindQuaZip5.patch")
- #t))
- (add-after 'install 'wrap
- ;; The program fails to find the QtWebEngineProcess program,
- ;; so we set QTWEBENGINEPROCESS_PATH to help it.
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((bin (string-append (assoc-ref outputs "out") "/bin"))
- (qtwebengineprocess (string-append
- (assoc-ref inputs "qtwebengine")
- "/lib/qt5/libexec/QtWebEngineProcess")))
- (for-each (lambda (program)
- (wrap-program program
- `("QTWEBENGINEPROCESS_PATH" =
- (,qtwebengineprocess))))
- (find-files bin ".*")))
- #t)))))
+ (invoke "patch" "-p1" "-i" "FindQuaZip5.patch"))))))
(synopsis "GPS mapping application")
(description
"QMapShack can be used to plan your next outdoor trip or to visualize and