summaryrefslogtreecommitdiff
path: root/gnu/packages/geeqie.scm
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2016-12-02 12:24:40 +0300
committerAlex Kost <alezost@gmail.com>2016-12-04 17:39:48 +0300
commit023f0fb06ee8dd55f95ff1be542e805363535b97 (patch)
tree513d311fdf5409071022c083e656ec71a9e9c8d9 /gnu/packages/geeqie.scm
parentc3a10d30d15d7f4b70c9f23cc20a498079fcf77f (diff)
downloadguix-patches-023f0fb06ee8dd55f95ff1be542e805363535b97.tar
guix-patches-023f0fb06ee8dd55f95ff1be542e805363535b97.tar.gz
gnu: exiv2: Move to (gnu packages image).
* gnu/packages/geeqie.scm (exiv2): Move to... * gnu/packages/image.scm: ... here. * gnu/packages/gnome.scm: Adjust the used modules. * gnu/packages/gnunet.scm: Likewise. * gnu/packages/gps.scm: Likewise.
Diffstat (limited to 'gnu/packages/geeqie.scm')
-rw-r--r--gnu/packages/geeqie.scm33
1 files changed, 0 insertions, 33 deletions
diff --git a/gnu/packages/geeqie.scm b/gnu/packages/geeqie.scm
index 509819e780..bc922d577a 100644
--- a/gnu/packages/geeqie.scm
+++ b/gnu/packages/geeqie.scm
@@ -31,39 +31,6 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages xml))
-(define-public exiv2 ; XXX: move elsewhere?
- (package
- (name "exiv2")
- (version "0.25")
- (source (origin
- (method url-fetch)
- (uri (list (string-append "http://www.exiv2.org/exiv2-"
- version ".tar.gz")
- (string-append "https://fossies.org/linux/misc/exiv2-"
- version ".tar.gz")))
- (sha256
- (base32
- "197g6vgcpyf9p2cwn5p5hb1r714xsk1v4p96f5pv1z8mi9vzq2y8"))))
- (build-system gnu-build-system)
- (arguments '(#:tests? #f)) ; no `check' target
- (propagated-inputs
- `(("expat" ,expat)
- ("zlib" ,zlib)))
- (native-inputs
- `(("intltool" ,intltool)))
- (home-page "http://www.exiv2.org/")
- (synopsis "Library and command-line utility to manage image metadata")
- (description
- "Exiv2 is a C++ library and a command line utility to manage image
-metadata. It provides fast and easy read and write access to the Exif, IPTC
-and XMP metadata of images in various formats.")
-
- ;; Files under `xmpsdk' are a copy of Adobe's XMP SDK, licensed under the
- ;; 3-clause BSD license: <http://www.adobe.com/devnet/xmp/sdk/eula.html>.
- ;; The core is GPLv2+:
- ;; <https://launchpad.net/ubuntu/precise/+source/exiv2/+copyright>.
- (license l:gpl2+)))
-
(define-public geeqie
(package
(name "geeqie")