summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-04-26 22:51:07 +0200
committerLudovic Courtès <ludo@gnu.org>2013-04-26 22:51:07 +0200
commit3b401612d9ea23cf20f5377594251a82c28e03e6 (patch)
tree938062c965f087abc89135ae20b00ae3d8b7e3bc /gnu/packages/gcc.scm
parent6aded2dd3fdeb349f18e9085bf700ea1bb926c0b (diff)
downloadguix-patches-3b401612d9ea23cf20f5377594251a82c28e03e6.tar
guix-patches-3b401612d9ea23cf20f5377594251a82c28e03e6.tar.gz
gnu: Binutils 2.23.2 and GCC 4.7.3.
* gnu/packages/base.scm (binutils): Update to 2.23.2. (binutils-2.23, ld-wrapper-2.23): Remove. (gcc-4.8): Move to... * gnu/packages/gcc.scm (gcc-4.8): ... here. (gcc-4.7): Update to 4.7.3. Add dependencies on ISL, CLooG, libelf, and zlib.
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm26
1 files changed, 21 insertions, 5 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 96b82d5af7..d239b5a9ab 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -35,18 +35,22 @@
(let ((stripped? #t)) ; TODO: make this a parameter
(package
(name "gcc")
- (version "4.7.2")
+ (version "4.7.3")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/gcc/gcc-"
version "/gcc-" version ".tar.bz2"))
(sha256
(base32
- "115h03hil99ljig8lkrq4qk426awmzh0g99wrrggxf8g07bq74la"))))
+ "1hx9h64ivarlzi4hxvq42as5m9vlr5cyzaaq4gzj4i619zmkfz1g"))))
(build-system gnu-build-system)
- (inputs `(("gmp" ,gmp)
- ("mpfr" ,mpfr)
- ("mpc" ,mpc))) ; TODO: libelf, ppl, cloog, zlib, etc.
+ (inputs `(("gmp" ,gmp)
+ ("mpfr" ,mpfr)
+ ("mpc" ,mpc)
+ ("isl" ,isl)
+ ("cloog" ,cloog)
+ ("libelf" ,libelf)
+ ("zlib" ,zlib)))
(arguments
`(#:out-of-source? #t
#:strip-binaries? ,stripped?
@@ -152,6 +156,18 @@ used in the GNU system including the GNU/Linux variant.")
(license gpl3+)
(home-page "http://gcc.gnu.org/"))))
+(define-public gcc-4.8
+ ;; FIXME: Move to gcc.scm when Binutils is updated.
+ (package (inherit gcc-4.7)
+ (version "4.8.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/gcc/gcc-"
+ version "/gcc-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0b6cp9d1sas3vq6dj3zrgd134p9b569fqhbixb9cl7mp698zwdxh"))))))
+
(define-public isl
(package
(name "isl")