summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-09-09 15:22:45 +0200
committerLudovic Courtès <ludo@gnu.org>2016-09-12 18:20:50 +0200
commite7e43727ce7b3426a31b2f50b035a5b0aba61d52 (patch)
tree6fda0b61a2832e7a545c206259f2ba4eca90f726 /gnu/packages/gcc.scm
parent24f2334e367e6218617f21e3abb287b211a1dcd1 (diff)
downloadguix-patches-e7e43727ce7b3426a31b2f50b035a5b0aba61d52.tar
guix-patches-e7e43727ce7b3426a31b2f50b035a5b0aba61d52.tar.gz
gnu: gcc: Work around ARM bootstrapping failure (GCC bug #71399).
* gnu/packages/patches/gcc-arm-bug-71399.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/gcc.scm (gcc-4.9)[source]: Use it.
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index f99dfa5052..da66525707 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -340,7 +340,8 @@ Go. It also includes runtime support libraries for these languages.")
(sha256
(base32
"14l06m7nvcvb0igkbip58x59w3nq6315k6jcz3wr9ch1rn9d44bc"))
- (patches (search-patches "gcc-libvtv-runpath.patch"))))))
+ (patches (search-patches "gcc-arm-bug-71399.patch"
+ "gcc-libvtv-runpath.patch"))))))
(define-public gcc-5
;; Note: GCC >= 5 ships with .info files but 'make install' fails to install