summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-11-09 21:20:00 +0100
committerLudovic Courtès <ludo@gnu.org>2016-11-09 21:24:44 +0100
commit8033772363b287ca529461e575ceb4a69d7af942 (patch)
tree696c581a27ea02b53c2599f616fecaa0b8865626 /gnu/packages/gcc.scm
parentc169d91e5a0be92b6bd48a8fd98c43078d2a12ef (diff)
downloadguix-patches-8033772363b287ca529461e575ceb4a69d7af942.tar
guix-patches-8033772363b287ca529461e575ceb4a69d7af942.tar.gz
gnu: gcc@5, gcc@6: Work around use of 'movabs' for /gnu/store strings.
Partly addresses <http://bugs.gnu.org/24703>. Reported by Mark H Weaver <mhw@netris.org>. * gnu/packages/patches/gcc-strmov-store-file-names.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/gcc.scm (gcc-5)[sources](patches): Add it. (gcc-6)[sources](patches): Add it.
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index c961c84fca..1fad9da663 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -354,7 +354,8 @@ Go. It also includes runtime support libraries for these languages.")
(sha256
(base32
"1ny4smkp5bzs3cp8ss7pl6lk8yss0d9m4av1mvdp72r1x695akxq"))
- (patches (search-patches "gcc-5.0-libvtv-runpath.patch"))))))
+ (patches (search-patches "gcc-strmov-store-file-names.patch"
+ "gcc-5.0-libvtv-runpath.patch"))))))
(define-public gcc-6
(package
@@ -367,7 +368,8 @@ Go. It also includes runtime support libraries for these languages.")
(sha256
(base32
"1idpf43988v1a6i8lw9ak1r7igcfg1bm5kn011iydlr2qygmhi4r"))
- (patches (search-patches "gcc-5.0-libvtv-runpath.patch"))))))
+ (patches (search-patches "gcc-strmov-store-file-names.patch"
+ "gcc-5.0-libvtv-runpath.patch"))))))
;; Note: When changing the default gcc version, update
;; the gcc-toolchain-* definitions accordingly.