summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorJames Smith <jsubuntuxp@disroot.org>2024-06-16 14:43:13 -0700
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-06-23 10:09:01 +0200
commit617f1e5320d91e9e6ce8d177d2e0dba15cca682c (patch)
tree197cfc5290bdbde25006cfbf7a7b0a616d8c2271 /gnu/packages/games.scm
parent76d0debc19aea5c7d792d24698d741c55a91066c (diff)
downloadguix-patches-617f1e5320d91e9e6ce8d177d2e0dba15cca682c.tar
guix-patches-617f1e5320d91e9e6ce8d177d2e0dba15cca682c.tar.gz
gnu: quakespasm: Update package style.
* gnu/packages/games.scm (quakespasm)[arguments]: Convert to list of G-Expressions. <#:make-flags>: Use (cc-for-target) instead of gcc. <#:phases>: Simplify ‘fix-makefile-paths’. Remove trailing #t. Change-Id: I250a842c78f2f49b451e5df76509fbe6fa1b4576 Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm32
1 files changed, 15 insertions, 17 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 20b8916765..9274fc494d 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -7676,23 +7676,21 @@ abilities and powers.")
(sha256
(base32 "0hr58w1d2yw82vm9lkln05z6d4sjlcr6grxhf6sqdqwyfy9nv1mw"))))
(arguments
- `(#:tests? #f
- #:make-flags '("CC=gcc"
- "MP3LIB=mpg123"
- "USE_CODEC_FLAC=1"
- "USE_CODEC_MIKMOD=1"
- "USE_SDL2=1"
- "-CQuake")
- #:phases (modify-phases %standard-phases
- (delete 'configure)
- (add-after 'unpack 'fix-makefile-paths
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (mkdir-p (string-append out "/bin"))
- (substitute* "Quake/Makefile"
- (("/usr/local/games")
- (string-append out "/bin")))
- #t))))))
+ (list #:tests? #f
+ #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+ "MP3LIB=mpg123"
+ "USE_CODEC_FLAC=1"
+ "USE_CODEC_MIKMOD=1"
+ "USE_SDL2=1"
+ "-CQuake")
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'fix-makefile-paths
+ (lambda _
+ (mkdir-p (string-append #$output "/bin"))
+ (substitute* "Quake/Makefile"
+ (("/usr/local/games")
+ (string-append #$output "/bin"))))))))
(build-system gnu-build-system)
(inputs (list libmikmod
libvorbis