summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorStephen Webber <webber.sl@gmail.com>2016-10-16 15:04:35 -0500
committerChristopher Allan Webber <cwebber@dustycloud.org>2016-10-18 20:23:03 -0500
commita56145e1fa8c8c9cb866518efdeaaf4ad4017ba1 (patch)
tree63cf2172eec05f1d3bf607bbbde0864e832bfb6b /gnu/packages/games.scm
parent91988aee126376ea9e111882afb511e3a555936d (diff)
downloadguix-patches-a56145e1fa8c8c9cb866518efdeaaf4ad4017ba1.tar
guix-patches-a56145e1fa8c8c9cb866518efdeaaf4ad4017ba1.tar.gz
gnu: Add kobodeluxe.
* gnu/packages/games.scm (kobodeluxe): New variable. * gnu/packages/patches/kobodeluxe-paths.patch: New file. * gnu/packages/patches/kobodeluxe-enemies-pipe-decl.patch: New file. * gnu/packages/patches/kobodeluxe-const-charp-conversion.patch: New file. * gnu/packages/patches/kobodeluxe-manpage-minus-not-hyphen.patch: New file. * gnu/packages/patches/kobodeluxe-midicon-segmentation-fault.patch: New file. * gnu/packages/patches/kobodeluxe-graphics-window-signed-char.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 17ca12bce6..a2c8ac078a 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2016 Steve Webber <webber.sl@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2966,3 +2967,35 @@ symbols, the game needs graphics to render the non-euclidean world.")
license:public-domain ; src/direntx.*
license:zlib ; src/savepng.*
license:gpl2+)))) ; remaining files
+
+(define-public kobodeluxe
+ (package
+ (name "kobodeluxe")
+ (version "0.5.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://olofson.net/kobodl/download/KoboDeluxe-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "0b2wvdpnmaibsy419c16dfwj5kvd3pccby2aaqvm964x74592yqg"))
+ (patches (search-patches
+ "kobodeluxe-const-charp-conversion.patch"
+ "kobodeluxe-enemies-pipe-decl.patch"
+ "kobodeluxe-graphics-window-signed-char.patch"
+ "kobodeluxe-manpage-minus-not-hyphen.patch"
+ "kobodeluxe-midicon-segmentation-fault.patch"
+ "kobodeluxe-paths.patch"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags
+ (list (string-append "CPPFLAGS=-I"
+ (assoc-ref %build-inputs "sdl-union")
+ "/include/SDL"))))
+ (inputs `(("sdl-union" ,(sdl-union (list sdl sdl-image)))))
+ (synopsis "Shooter with space station destruction")
+ (description
+ "Kobo Deluxe is an enhanced version of Akira Higuchi's XKobo graphical game
+for Un*x systems with X11.")
+ (home-page "http://olofson.net/kobodl/")
+ (license license:gpl2+)))