summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2020-09-18 09:23:52 -0400
committerKei Kebreau <kkebreau@posteo.net>2020-09-20 13:32:41 -0400
commit5d351adaca9327f126f4996f29ebc041edb47c31 (patch)
tree988a49aed72e12711c7aae0068694813d4a74fcd /gnu/packages/games.scm
parentfb420edd20511dd408a1adb18eb1d025f73e2554 (diff)
downloadguix-patches-5d351adaca9327f126f4996f29ebc041edb47c31.tar
guix-patches-5d351adaca9327f126f4996f29ebc041edb47c31.tar.gz
gnu: retux: Update to 1.4.1-1.
* gnu/packages/games.scm (retux): Add let binding and update to 1.4.1-1. [version]: Update version string. [source]: Update URL.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm103
1 files changed, 54 insertions, 49 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 5903a31bd8..80d1659258 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1811,58 +1811,63 @@ Every puzzle has a complete solution, although there may be more than one.")
(license license:gpl2+)))
(define-public retux
- (package
- (name "retux")
- (version "1.4")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/retux-game/retux/"
- "releases/download/v"
- (version-major+minor version) "/retux-"
- version "-src.tar.gz"))
- (sha256
- (base32
- "1hxy1pvlxhk0ci3wh2i3mmr82faqdjnnxsiwwr5gcr93nfnw9w5f"))))
- (build-system python-build-system)
- (arguments
- `(#:tests? #f ; no check target
- #:phases
- (modify-phases %standard-phases
- ;; no setup.py script
- (delete 'build)
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin"))
- (data (string-append out "/share/retux")))
- (mkdir-p bin)
+ (let ((release "1.4.1")
+ (revision 1))
+ (package
+ (name "retux")
+ (version (if (zero? revision)
+ release
+ (string-append release "-"
+ (number->string revision))))
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/retux-game/retux/"
+ "releases/download/v"
+ version "/retux-"
+ release "-src.tar.gz"))
+ (sha256
+ (base32
+ "1vrldg2qh2gqfswj7vkpc589ldrrjd903j6cnfdik9zh0jhlq4h2"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f ; no check target
+ #:phases
+ (modify-phases %standard-phases
+ ;; no setup.py script
+ (delete 'build)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (data (string-append out "/share/retux")))
+ (mkdir-p bin)
- (substitute* "retux.py"
- ;; Use the correct data directory.
- (("os\\.path\\.join\\(os\\.path\\.dirname\\(__file__\\), \"data\"\\),")
- (string-append "\"" data "\",")))
+ (substitute* "retux.py"
+ ;; Use the correct data directory.
+ (("os\\.path\\.join\\(os\\.path\\.dirname\\(__file__\\), \"data\"\\),")
+ (string-append "\"" data "\",")))
- (copy-file "retux.py" (string-append bin "/retux"))
- (copy-recursively "data" data)
- #t))))))
- (inputs
- `(("python-sge-pygame" ,python-sge-pygame)
- ("python-six" ,python-six)
- ("python-xsge" ,python-xsge)))
- (home-page "https://retux-game.github.io/")
- (synopsis "Action platformer game")
- (description
- "ReTux is an action platformer loosely inspired by the Mario games,
+ (copy-file "retux.py" (string-append bin "/retux"))
+ (copy-recursively "data" data)
+ #t))))))
+ (inputs
+ `(("python-sge-pygame" ,python-sge-pygame)
+ ("python-six" ,python-six)
+ ("python-xsge" ,python-xsge)))
+ (home-page "https://retux-game.github.io/")
+ (synopsis "Action platformer game")
+ (description
+ "ReTux is an action platformer loosely inspired by the Mario games,
utilizing the art assets from the @code{SuperTux} project.")
- ;; GPL version 3 or later is the license for the code and some art.
- ;; The rest of the licenses are for the art exclusively, as listed in
- ;; data/LICENSES.
- (license (list license:cc0
- license:cc-by3.0
- license:cc-by-sa3.0
- license:cc-by-sa4.0
- license:gpl2+
- license:gpl3+))))
+ ;; GPL version 3 or later is the license for the code and some art.
+ ;; The rest of the licenses are for the art exclusively, as listed in
+ ;; data/LICENSES.
+ (license (list license:cc0
+ license:cc-by3.0
+ license:cc-by-sa3.0
+ license:cc-by-sa4.0
+ license:gpl2+
+ license:gpl3+)))))
(define-public roguebox-adventures
(package