summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2021-05-21 22:34:57 -0500
committerEric Bavier <bavier@member.fsf.org>2021-05-21 22:37:54 -0500
commita1a7a33b17706b51c455fb1a193226bf51e3a705 (patch)
treeea5b489d74b23ba4d4de6b90e22793f1f85e45d1 /gnu/packages/games.scm
parent8aab6e0dfbf0815eb295220e23cd58347697fb18 (diff)
downloadguix-patches-a1a7a33b17706b51c455fb1a193226bf51e3a705.tar
guix-patches-a1a7a33b17706b51c455fb1a193226bf51e3a705.tar.gz
gnu: pinball: Update to 3.1.20201218.
* gnu/packages/games.scm (pinball): Update to 3.1.20201218. [source]: Tarballs no longer published on sourceforge, so use git-fetch. [native-inputs]: New field for bootstrapping inputs. [inputs]: Add libltdl. [arguments]: Add custom 'bootstrap' phase. * gnu/packages/patches/pinball-system-ltdl.patch: Adjust to latest source. * gnu/packages/patches/pinball-const-fix.patch, gnu/packages/patches/pinball-cstddef.patch, gnu/packages/patches/pinball-missing-separators.patch, gnu/packages/patches/pinball-src-deps.patch: Delete upstreamed patches. * gnu/local.mk (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm38
1 files changed, 26 insertions, 12 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 6908d115f2..24e487a2b8 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4688,34 +4688,48 @@ images, etc.)")
(define-public pinball
(package
(name "pinball")
- (version "0.3.1")
+ (version "0.3.20201218")
(source
- (origin (method url-fetch)
- (uri (string-append "mirror://sourceforge/pinball/pinball/"
- "pinball-" version "/"
- "pinball-" version ".tar.gz"))
+ (origin (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/adoptware/pinball")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1f2whlrfidwfh8lvr8cspcyirc6840r5d1ajm7x99qmngygrhixs"))
- (patches (search-patches "pinball-const-fix.patch"
- "pinball-cstddef.patch"
- "pinball-missing-separators.patch"
- "pinball-src-deps.patch"
- "pinball-system-ltdl.patch"))))
+ "056jk98v6zlkrj9vjm06p0pmpnav1x658n6qw10v5klg5gr6ldf7"))
+ (patches (search-patches "pinball-system-ltdl.patch"))))
(build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)
+ ("libtool" ,libtool)))
(inputs
`(("glu" ,glu)
+ ("libltdl" ,libltdl)
("mesa" ,mesa)
("sdl" ,sdl)
("sdl-image" ,sdl-image)
("sdl-mixer" ,sdl-mixer)))
(arguments
'(#:configure-flags
+ ;; Configure tries to use pkg-config, but falls short, so:
(list (string-append "CPPFLAGS=-I"
(assoc-ref %build-inputs "sdl-image")
"/include/SDL -I"
(assoc-ref %build-inputs "sdl-mixer")
- "/include/SDL"))))
+ "/include/SDL"))
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'bootstrap
+ ;; The `bootstrap` script tries to call a script with
+ ;; `/usr/bin/make` in the shebang, but ultimately does the same as
+ ;; autoreconf would do, so just use that.
+ (lambda _
+ (symlink "README.md" "README")
+ (display (which "autoreconf")) (newline)
+ (invoke "autoreconf" "-vif"))))))
(home-page "http://pinball.sourceforge.net")
(synopsis "Pinball simulator")
(description "The Emilia Pinball Project is a pinball simulator. There