summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-05-23 13:43:56 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-05-23 22:39:14 +0200
commit363095f296bb49d4a43603e273706ae33ee061ac (patch)
tree579ea34c87780ac78afec1739d6ee867efdb1b6e /gnu/packages/games.scm
parent55244601d76b31082ab3c7f555d333d7cb106e89 (diff)
downloadguix-patches-363095f296bb49d4a43603e273706ae33ee061ac.tar
guix-patches-363095f296bb49d4a43603e273706ae33ee061ac.tar.gz
gnu: ltris: Update to 1.2.3.
* gnu/packages/games.scm (ltris): Update to 1.2.3. [arguments]: Remove unnecessary #:configure-flags.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 24e487a2b8..6f07cd3aa9 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1836,19 +1836,17 @@ Chess). It is similar to standard chess but this variant is far more complicate
(define-public ltris
(package
(name "ltris")
- (version "1.2.1")
+ (version "1.2.3")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/lgames/ltris/"
"ltris-" version ".tar.gz"))
(sha256
- (base32 "0959vvxh5xnxzpdv7i67lpd2b6ghx69z65ldnclj1z6llyfzfs7q"))))
+ (base32 "1a2m17jwkyar8gj07bn5jk01j2ps4vvc48z955jjjsh67q2svi0f"))))
(build-system gnu-build-system)
(arguments
- '(;; The code in LTris uses traditional GNU semantics for inline functions
- #:configure-flags '("CFLAGS=-fgnu89-inline")
- #:phases
+ '(#:phases
(modify-phases %standard-phases
(add-after 'set-paths 'set-sdl-paths
(lambda* (#:key inputs #:allow-other-keys)