summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-03 17:15:19 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-03 19:23:50 +0200
commitd536083f3353aed7fab6b88b3d1758f3f1e33884 (patch)
treeead1a427c9a7d6787e7d8ffeb24d4826858921a4 /gnu/packages/games.scm
parentd9ac466b7f373ef735b08c13aa686336b32294c5 (diff)
downloadguix-patches-d536083f3353aed7fab6b88b3d1758f3f1e33884.tar
guix-patches-d536083f3353aed7fab6b88b3d1758f3f1e33884.tar.gz
gnu: freeorion: Don't use unstable tarball.
* gnu/packages/games.scm (freeorion)[source]: Use GIT-FETCH and GIT-FILE-NAME. Remove explicit #t snippet return value.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 419a114272..cbdc38d0ee 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -10032,18 +10032,18 @@ win.")
(version "0.4.10")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/freeorion/freeorion/releases/"
- "download/v" version "/FreeOrion_v" version
- "_2020-07-10.f3d403e_Source.tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/freeorion/freeorion")
+ (commit (string-append "v" version))))
(sha256
- (base32 "12xspixrkx6mmmsdqjha0hg02r4y73pk229l0wjq9s0yp8nb8ap7"))
+ (base32 "1hq212pbsqpgn193wkvcl45m8bjvx730486xkffivylxgbiyvv2c"))
+ (file-name (git-file-name name version))
(modules '((guix build utils)))
(snippet
'(begin
;; There are some bundled fonts.
- (for-each delete-file-recursively '("default/data/fonts"))
- #t))))
+ (for-each delete-file-recursively '("default/data/fonts"))))))
(build-system cmake-build-system)
(arguments
'(#:tests? #f ;no test