summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2017-12-10 11:15:03 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-12-18 01:16:04 +0100
commit01564e5ab5b9c11fea81a87ac7f8d2fcdb81668d (patch)
tree39f44d8fba07c21780c0cdc6effdb73764513b77 /gnu/packages/games.scm
parent9286e0ec81b1b2c9c90d997d0465997641bdb910 (diff)
downloadguix-patches-01564e5ab5b9c11fea81a87ac7f8d2fcdb81668d.tar
guix-patches-01564e5ab5b9c11fea81a87ac7f8d2fcdb81668d.tar.gz
gnu: retroarch: Enable Vulkan support.
* gnu/packages/games.scm (retroarch)[arguments]: Hard-code the path to libvulkan.so. [inputs]: Add vulkan-icd-loader. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a699fadc2a..398ab4e9b5 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -134,6 +134,7 @@
#:use-module (gnu packages gnuzilla)
#:use-module (gnu packages icu4c)
#:use-module (gnu packages networking)
+ #:use-module (gnu packages vulkan)
#:use-module (gnu packages web)
#:use-module (guix build-system gnu)
#:use-module (guix build-system haskell)
@@ -1443,9 +1444,13 @@ either by Infocom or created using the Inform compiler.")
#:phases
(modify-phases %standard-phases
(replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
+ (lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
- (etc (string-append out "/etc")))
+ (etc (string-append out "/etc"))
+ (vulkan (assoc-ref inputs "vulkan-icd-loader")))
+ ;; Hard-code the path to libvulkan.so.
+ (substitute* "gfx/common/vulkan_common.c"
+ (("libvulkan.so") (string-append vulkan "/lib/libvulkan.so")))
(substitute* "qb/qb.libs.sh"
(("/bin/true") (which "true")))
;; The configure script does not yet accept the extra arguments
@@ -1468,6 +1473,7 @@ either by Infocom or created using the Inform compiler.")
("python" ,python)
("sdl" ,sdl2)
("udev" ,eudev)
+ ("vulkan-icd-loader" ,vulkan-icd-loader)
("wayland", wayland)
("zlib" ,zlib)))
(native-inputs