summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-08-03 17:52:03 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-12-22 07:56:55 +0100
commit5145001a1536e64d63693ab3daf0f86c55e35a79 (patch)
tree23e9c57c937add8f76edd00f2034b78ca3b5b9e5 /gnu/packages/games.scm
parent5f66a0a78b4a5c05d7bb82523100d210b893cf9b (diff)
downloadguix-patches-5145001a1536e64d63693ab3daf0f86c55e35a79.tar
guix-patches-5145001a1536e64d63693ab3daf0f86c55e35a79.tar.gz
gnu: Add meandmyshadow.
* gnu/packages/games.scm (meandmyshadow): New variable.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm50
1 files changed, 50 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index c494d0beba..2b1bddb2f8 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -354,6 +354,56 @@ played. Freedoom complements the Doom engine with free levels, artwork, sound
effects and music to make a completely free game.")
(license license:bsd-3)))
+(define-public meandmyshadow
+ (package
+ (name "meandmyshadow")
+ (version "0.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/meandmyshadow/"
+ version "/meandmyshadow-" version
+ "-src.tar.gz"))
+ (sha256
+ (base32
+ "1dpb7s32b2psj5w3nr5kqibib8nndi86mw8gxp4hmxwrfiisf86d"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:tests? #f ; there are no tests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'set-sdl'paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "cmake/Modules/FindSDL_gfx.cmake"
+ (("/usr/local/include/SDL")
+ (string-append (assoc-ref inputs "sdl")
+ "/include/SDL")))
+ ;; Because SDL provides lib/libX11.so.6 we need to explicitly
+ ;; link with libX11, even though we're using the GL backend.
+ (substitute* "CMakeLists.txt"
+ (("\\$\\{X11_LIBRARIES\\}") "-lX11"))
+ )))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("sdl" ,(sdl-union (list sdl
+ sdl-image
+ sdl-gfx
+ sdl-mixer
+ sdl-ttf)))
+ ("libx11" ,libx11) ; needed by sdl's libX11
+ ("libarchive" ,libarchive)
+ ("openssl" ,openssl)
+ ("mesa" ,mesa)
+ ("glu" ,glu)
+ ("curl" ,curl)))
+ (home-page "http://meandmyshadow.sourceforge.net/")
+ (synopsis "Puzzle/platform game")
+ (description "Me and My Shadow is a puzzle/platform game in which you try
+to reach the exit by solving puzzles. Spikes, moving blocks, fragile blocks
+and much more stand between you and the exit. Record your moves and let your
+shadow mimic them to reach blocks you couldn't reach alone.")
+ (license license:gpl3+)))
+
(define-public knights
(package
(name "knights")