summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-26 16:33:27 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-26 16:33:27 +0100
commit48dbb1bf2b60d6025a544f4b59b4452088331e09 (patch)
tree69ced728e02ea0c4e16c50828a7667de2e7ce9ae /gnu/packages/games.scm
parenta4aca0b88cacad59373435385e4ed78dc451f197 (diff)
downloadguix-patches-48dbb1bf2b60d6025a544f4b59b4452088331e09.tar
guix-patches-48dbb1bf2b60d6025a544f4b59b4452088331e09.tar.gz
gnu: xboing: Use INVOKE.
* gnu/packages/games.scm (xboing)[arguments]: Use INVOKE in build phases. Do not replace "install" phase; add new "install-man-pages" phase instead.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm14
1 files changed, 5 insertions, 9 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 9c782303e2..6100ca79d7 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1533,7 +1533,6 @@ fully interactive graphical interface and it can load and save games in the
Portable Game Notation.")
(license license:gpl3+)))
-
(define-public xboing
(package
(name "xboing")
@@ -1564,14 +1563,11 @@ Portable Game Notation.")
;; FIXME: HIGH_SCORE_FILE should be set to somewhere writeable
- (zero? (system* "xmkmf" "-a"
- (string-append "-DProjectRoot="
- (assoc-ref outputs "out"))))))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (and
- (zero? (system* "make" "install.man"))
- (zero? (system* "make" "install"))))))))
+ (invoke "xmkmf" "-a"
+ (string-append "-DProjectRoot="
+ (assoc-ref outputs "out")))))
+ (add-before 'install 'install-man-pages
+ (lambda _ (invoke "make" "install.man"))))))
(inputs `(("libx11" ,libx11)
("libxext" ,libxext)
("libxpm" ,libxpm)))