summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2022-01-01 18:34:14 +0000
committerLeo Famulari <leo@famulari.name>2022-01-01 23:22:59 -0500
commita83dc5022b70d4ee96741311553c65bc636625ae (patch)
tree62d59db7e0a2377766293183733683973be081c0 /gnu/packages/games.scm
parent6f83a503af908fdd732765e1327c6afb8f53f3d2 (diff)
downloadguix-patches-a83dc5022b70d4ee96741311553c65bc636625ae.tar
guix-patches-a83dc5022b70d4ee96741311553c65bc636625ae.tar.gz
gnu: widelands: Fix build against boost 1.77.
Widelands fails to build with boost 1.77 due to a missing include in one of Wideland's header files that was previously indirectly included by boost 1.76. * gnu/packages/patches/widelands-add-missing-map-include.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/games.scm (widelands)[source]: Add patch. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index d4653c912e..c61dafc7a0 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -61,7 +61,7 @@
;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
;;; Copyright © 2021 David Pflug <david@pflug.io>
-;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2021, 2022 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2021 Solene Rapenne <solene@perso.pw>
;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
@@ -5135,7 +5135,8 @@ tactics.")
(patches
;; Use system Minizip. Patch is provided by Debian, and discussed
;; upstream at <https://github.com/widelands/widelands/issues/399>.
- (search-patches "widelands-system-wide_minizip.patch"))))
+ (search-patches "widelands-system-wide_minizip.patch"
+ "widelands-add-missing-map-include.patch"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags