summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-09-16 10:31:25 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-09-16 10:31:25 +0200
commit7ceafdf0726e118dd6d6e00e5f5f9e03b13082c1 (patch)
tree1e819550a2b0a4f0d271c0b7475551437b25db44 /gnu/packages/games.scm
parentbbdc4d73476bdf81842e09fd99dd843c22a0b53a (diff)
downloadguix-patches-7ceafdf0726e118dd6d6e00e5f5f9e03b13082c1.tar
guix-patches-7ceafdf0726e118dd6d6e00e5f5f9e03b13082c1.tar.gz
gnu: crispy-doom: Fix build.
* gnu/packages/games.scm (crispy-doom)[arguments]: Pass '-fcommon' to CFLAGS.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 9090fb6fab..ca28ec0c32 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -7509,7 +7509,8 @@ affect gameplay).")
`(("automake" ,automake)
("autoreconf" ,autoconf))))
(arguments
- `(#:phases
+ `(#:configure-flags '("CFLAGS=-fcommon")
+ #:phases
(modify-phases %standard-phases
(replace 'bootstrap
;; The bundled autogen.sh script unconditionally runs ./configure.