summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2017-11-22 10:07:59 +0100
committerLudovic Courtès <ludo@gnu.org>2017-11-23 23:19:02 +0100
commit17c3f77641f19249b99283d81f08cdcfb7f52776 (patch)
treec766726fd82800fb73aec003d9db9a24998c6e59 /gnu/packages/games.scm
parent5864f1c1ee435fefa707cc644b88d99a2e89ff98 (diff)
downloadguix-patches-17c3f77641f19249b99283d81f08cdcfb7f52776.tar
guix-patches-17c3f77641f19249b99283d81f08cdcfb7f52776.tar.gz
gnu: supertuxkart: Update to 0.9.3.
* gnu/packages/games.scm (supertuxkart): Update to 0.9.3. [arguments] <#:configure-flags>: Pass -DBUILD_RECORDER=0. * gnu/packages/patches/supertuxkart-angelscript-ftbfs.patch: Remove. * gnu/local.mk (dist_patch_DATA): Remove it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index c37491dc6b..b1ba28a62c 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1461,7 +1461,7 @@ This game is based on the GPL version of the famous game TuxRacer.")
(define-public supertuxkart
(package
(name "supertuxkart")
- (version "0.9.2")
+ (version "0.9.3")
(source
(origin
(method url-fetch)
@@ -1469,8 +1469,7 @@ This game is based on the GPL version of the famous game TuxRacer.")
version "/supertuxkart-" version "-src.tar.xz"))
(sha256
(base32
- "10l2ljmd7mv8f9ylarqmxxryicdnph2qkm3g5maxnsm2k2q0n20b"))
- (patches (search-patches "supertuxkart-angelscript-ftbfs.patch"))
+ "1c4w47ibj87lgwiqygq8qi7jiz6gklj4dwf5bs5zk15s0rqlw0fq"))
(modules '((guix build utils)))
(snippet
;; Delete bundled library sources
@@ -1495,6 +1494,8 @@ This game is based on the GPL version of the famous game TuxRacer.")
(list "-DUSE_WIIUSE=0"
;; Do not use the bundled zlib
"-DNO_IRR_COMPILE_WITH_ZLIB_=TRUE"
+ ;; FIXME: needs libopenglrecorder
+ "-DBUILD_RECORDER=0"
;; Irrlicht returns an integer instead of a boolean
"-DCMAKE_C_FLAGS=-fpermissive")
#:phases