summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-06-18 23:33:34 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-06-18 23:56:35 +0200
commitb69d1c568c3f868b244884da5d33453f53ab9387 (patch)
tree87f02639ba90bb728648243cac4f07aeb6e804b3 /gnu/packages/game-development.scm
parentd15472d3966c78e895109672743935208263ef3a (diff)
downloadguix-patches-b69d1c568c3f868b244884da5d33453f53ab9387.tar
guix-patches-b69d1c568c3f868b244884da5d33453f53ab9387.tar.gz
gnu: flatzebra: Update to 0.2.0.
* gnu/packages/game-development.scm (flatzebra): Update to 0.2.0. [arguments]: Remove phase. [inputs]: Remove SDL-UNION, SDL, SDL-IMAGE and SDL-MIXER. Add SDL2, SDL2-GFX, SDL2-IMAGE, SDL2-MIXER and SDL2-TTF. Change-Id: If37ab1732e2d984ebc9455cf89c5bfbf32ee20c2
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm20
1 files changed, 3 insertions, 17 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 3ea5bc979c..184a0d8e65 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -2764,33 +2764,19 @@ specific knowledge of the hardware they are targeting.")
(define-public flatzebra
(package
(name "flatzebra")
- (version "0.1.7")
+ (version "0.2.0")
(source
(origin
(method url-fetch)
(uri (string-append "http://perso.b2b2c.ca/~sarrazip/dev/"
"flatzebra-" version ".tar.gz"))
(sha256
- (base32 "1x2dy41c8vrq62bn03b82fpmk7x4rzd7qqiwvq0mgcl5rmasc2c8"))))
+ (base32 "1p1igi757m9a46v29mm7r40x61kdj7j66b9dbn53l5yfhnwa4w93"))))
(build-system gnu-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-sdl-config
- (lambda* (#:key inputs #:allow-other-keys)
- ;; XXX: sdl-config in sdl-union is a link to sdl-config from
- ;; plain sdl package. As a consequence, the prefix is wrong.
- ;; Force correct one with "--prefix" argument.
- (let ((sdl-union (assoc-ref inputs "sdl")))
- (setenv "SDL_CONFIG"
- (string-append sdl-union
- "/bin/sdl-config --prefix="
- sdl-union)))
- #t)))))
(native-inputs
(list pkg-config))
(inputs
- `(("sdl" ,(sdl-union (list sdl sdl-image sdl-mixer)))))
+ (list sdl2 sdl2-gfx sdl2-image sdl2-mixer sdl2-ttf))
(home-page "http://perso.b2b2c.ca/~sarrazip/dev/burgerspace.html")
(synopsis "Generic game engine for 2D double-buffering animation")
(description