summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-05 19:17:41 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-05 19:17:41 +0100
commit9bc0f45df5d6aed217020b1183dca54989844fb0 (patch)
treed927e89949ff7f65b5059bc94273c53fd43d0763 /gnu/packages/game-development.scm
parent6db3c536e89deb8a204e756f427614925a7d2582 (diff)
parent10554e0a57feeea470127a1d0441957d1776b0bd (diff)
downloadguix-patches-9bc0f45df5d6aed217020b1183dca54989844fb0.tar
guix-patches-9bc0f45df5d6aed217020b1183dca54989844fb0.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm15
1 files changed, 10 insertions, 5 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index d148a6a8ff..30a1b3d6a1 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2021 Dmitry Polyakov <polyakov@liltechdude.xyz>
;;; Copyright © 2020-2021 James Smith <jsubuntuxp@disroot.org>
;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
+;;; Copyright © 2021 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -112,7 +113,7 @@
(define-public bullet
(package
(name "bullet")
- (version "2.89")
+ (version "3.17")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -121,7 +122,7 @@
(file-name (git-file-name name version))
(sha256
(base32
- "10ncf2z474jnv7p5lv01ak2mk2hib3rj5rz1zr8v2v5pnciqbijl"))
+ "0x1ghxbkvqr910sp01sjf4hlfy4sdgn2jx2qf0dsi697bzq1f3mr"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -131,9 +132,7 @@
'("Gwen" "clsocket" "enet" "glad" "imgui"
"lua-5.2.3" "midi" "minizip" "openvr"
"optionalX11" "serial" "zlib")))
- ;; These need files from ThirdPartyLibs.
- (substitute* "Extras/CMakeLists.txt"
- (("BulletRobotics") ""))
+
;; Tests fail on linking, cannot find -lBussIK.
(substitute* "test/CMakeLists.txt"
((" InverseDynamics")
@@ -146,6 +145,12 @@
"-DBUILD_CPU_DEMOS=OFF"
"-DBUILD_OPENGL3_DEMOS=OFF"
"-DBUILD_BULLET2_DEMOS=OFF"
+ ;; Extras/BulletRoboticsGUI needs files from
+ ;; ThirdPartyLibs
+ "-DBUILD_BULLET_ROBOTICS_GUI_EXTRA=OFF"
+ ;; Extras/BulletRobotics needs files from
+ ;; ThirdPartyLibs
+ "-DBUILD_BULLET_ROBOTICS_EXTRA=OFF"
(string-append "-DCMAKE_CXX_FLAGS=-fPIC "
(or (getenv "CXXFLAGS") "")))
#:phases