summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-20 00:35:19 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-20 00:39:16 +0200
commit4d82dbea45a00a6cec9df736b3c1506f9050065b (patch)
tree32ddb72ef67b427c68d0e0e9aa98b73b399cd577 /gnu/packages/game-development.scm
parent96c747cb29c0b762c8a2999a3dcc16085efd3e46 (diff)
downloadguix-patches-4d82dbea45a00a6cec9df736b3c1506f9050065b.tar
guix-patches-4d82dbea45a00a6cec9df736b3c1506f9050065b.tar.gz
gnu: allegro: Update to 4.4.3.1.
* gnu/packages/game-development.scm (allegro): Update to 4.4.3.1. [arguments]: Don't explicitly return #t from phases.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index a22167e31b..d7bcfc1741 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -866,7 +866,7 @@ package is the Nuklear bindings for LÖVE created by Kevin Harrison.")
(define-public allegro-4
(package
(name "allegro")
- (version "4.4.3")
+ (version "4.4.3.1")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/liballeg/allegro5/"
@@ -874,7 +874,7 @@ package is the Nuklear bindings for LÖVE created by Kevin Harrison.")
version ".tar.gz"))
(sha256
(base32
- "1d5ws3ihvpa6f4qc6a6drq31pajw6bblxifr4kcxzqj9br1nw28y"))))
+ "1m6lz35nk07dli26kkwz3wa50jsrxs1kb6w1nj14a911l34xn6gc"))))
(build-system cmake-build-system)
(arguments
'(#:phases
@@ -886,8 +886,7 @@ package is the Nuklear bindings for LÖVE created by Kevin Harrison.")
;; unconditionally clobbered in the build script.
(substitute* '("CMakeLists.txt")
(("ADDON_LINKAGE STATIC")
- "ADDON_LINKAGE SHARED"))
- #t)))))
+ "ADDON_LINKAGE SHARED")))))))
(inputs
`(("glu" ,glu)
("libpng" ,libpng)