summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorAndy Tai <atai@atai.org>2021-12-01 15:49:39 -0800
committerLeo Famulari <leo@famulari.name>2021-12-02 00:02:47 -0500
commitdd4365efa1c6fb609de9bd7cd10f9c82e064aed4 (patch)
treea2e7f6e3f8794d2759eccbb6cd221c7127b06766 /gnu/packages/game-development.scm
parent7a171235afb481ed6a9b8ef34a819d2385d39cad (diff)
downloadguix-patches-dd4365efa1c6fb609de9bd7cd10f9c82e064aed4.tar
guix-patches-dd4365efa1c6fb609de9bd7cd10f9c82e064aed4.tar.gz
gnu: godot: Update to 3.4.
* gnu/packages/game-development.scm (godot): Update to 3.4. [source]: Add new bundled dependencies to the origin snippet. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index a060dc94dc..380b5705d0 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1846,7 +1846,7 @@ games.")
(define-public godot
(package
(name "godot")
- (version "3.2.3")
+ (version "3.4")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1855,7 +1855,7 @@ games.")
(file-name (git-file-name name version))
(sha256
(base32
- "19vrp5lhyvxbm6wjxzn28sn3i0s8j08ca7nani8l1nrhvlc8wi0v"))
+ "0y542zla6msgxf31rd0349d9j3ya7f3njnwmmrh8lmzfgxx86qbx"))
(modules '((guix build utils)
(ice-9 ftw)
(srfi srfi-1)))
@@ -1870,19 +1870,23 @@ games.")
"assimp"
"certs"
"cvtt"
+ "embree"
"enet"
"etc2comp"
"fonts"
"glad"
"jpeg-compressor"
"libsimplewebm"
+ "minimp3"
"miniupnpc"
"minizip"
"misc"
"nanosvg"
+ "oidn"
"pvrtccompressor"
"recastnavigation"
"squish"
+ "stb_rect_pack"
"tinyexr"
"vhacd"
"xatlas")))
@@ -1969,6 +1973,7 @@ games.")
(native-inputs `(("pkg-config" ,pkg-config)))
(inputs `(("alsa-lib" ,alsa-lib)
("bullet" ,bullet)
+ ("eudev" ,eudev)
("freetype" ,freetype)
("glew" ,glew)
("glu" ,glu)