summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorAndy Tai <atai@atai.org>2021-12-05 23:19:31 -0800
committerLeo Famulari <leo@famulari.name>2021-12-10 11:18:59 -0500
commitaf067eaff4220ea1e86099894087b619606010b2 (patch)
tree791cc462afd4bff00d7406178ec22986dd237162 /gnu/packages/game-development.scm
parent53d69a60e72e2c1722ac6281bb923183fd051fcf (diff)
downloadguix-patches-af067eaff4220ea1e86099894087b619606010b2.tar
guix-patches-af067eaff4220ea1e86099894087b619606010b2.tar.gz
gnu: godot: Update to 3.4.
* gnu/packages/game-development.scm (godot): Update to 3.4. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm22
1 files changed, 20 insertions, 2 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index a060dc94dc..ed733e317f 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1846,7 +1846,7 @@ games.")
(define-public godot
(package
(name "godot")
- (version "3.2.3")
+ (version "3.4")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1855,7 +1855,7 @@ games.")
(file-name (git-file-name name version))
(sha256
(base32
- "19vrp5lhyvxbm6wjxzn28sn3i0s8j08ca7nani8l1nrhvlc8wi0v"))
+ "0y542zla6msgxf31rd0349d9j3ya7f3njnwmmrh8lmzfgxx86qbx"))
(modules '((guix build utils)
(ice-9 ftw)
(srfi srfi-1)))
@@ -1870,19 +1870,23 @@ games.")
"assimp"
"certs"
"cvtt"
+ "embree"
"enet"
"etc2comp"
"fonts"
"glad"
"jpeg-compressor"
"libsimplewebm"
+ "minimp3"
"miniupnpc"
"minizip"
"misc"
"nanosvg"
+ "oidn"
"pvrtccompressor"
"recastnavigation"
"squish"
+ "stb_rect_pack"
"tinyexr"
"vhacd"
"xatlas")))
@@ -1950,6 +1954,19 @@ games.")
(wrap-program (string-append out "/bin/godot")
`("PATH" ":" prefix (,(string-append zenity "/bin")))))
#t))
+ (add-after 'install 'wrap
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ ;; FIXME: Mesa tries to dlopen libudev.so.0 and fails. Pending a
+ ;; fix of the mesa package we wrap the pcb executable such that
+ ;; Mesa can find libudev.so.0 through LD_LIBRARY_PATH.
+ ;; also append ld path for pulseaudio and alsa-lib
+ (let* ((out (assoc-ref outputs "out"))
+ (udev_path (string-append (assoc-ref inputs "udev") "/lib"))
+ (pulseaudio_path (string-append (assoc-ref inputs "pulseaudio") "/lib"))
+ (alas_lib_path (string-append (assoc-ref inputs "alsa-lib") "/lib")))
+ (wrap-program (string-append out "/bin/godot")
+ `("LD_LIBRARY_PATH" ":" prefix (,udev_path ,pulseaudio_path ,alas_lib_path))))
+ #t))
(add-after 'install 'install-godot-desktop
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -1986,6 +2003,7 @@ games.")
("opusfile" ,opusfile)
("pcre2" ,pcre2)
("pulseaudio" ,pulseaudio)
+ ("udev" ,eudev) ;FIXME: required by mesa
("wslay" ,wslay)
("zenity" ,zenity)
("zstd" ,zstd "lib")))