summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2021-10-10 17:26:21 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2021-10-10 17:32:52 +0200
commitdd9fa204eb80e98101578ef39d4d5fc3d336ccb8 (patch)
treea86e85fad378f17131ea39209cc2276f8604bac1 /gnu/packages/game-development.scm
parent5464af0765ea922f9ba4791a3f41552776006ae7 (diff)
downloadguix-patches-dd9fa204eb80e98101578ef39d4d5fc3d336ccb8.tar
guix-patches-dd9fa204eb80e98101578ef39d4d5fc3d336ccb8.tar.gz
gnu: tsukundere: Unset LD_LIBRARY_PATH.
As of Guile-SDL2 version 0.7.0, which got committed in 73bb0b64855e07e17e73acbea4616ffa44630250, LD_LIBRARY_PATH is used to determine the location of SDL libraries if set. However, the presence of said environment variable does not always point to relative SDL libraries, thus causing an import of sdl2 modules to fail. * gnu/packages/game-development.scm (tsukundere)[#:phases]: Unset LD_LIBRARY_PATH in tsukundere.scm.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 01db2364df..a22167e31b 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -602,6 +602,9 @@ clone.")
(substitute* "tsukundere.scm"
(("exec guile (.*)" _ args)
(string-append
+ ;; XXX: Prevent Guile-SDL2 from blowing up by not knowing
+ ;; where the SDL2 libaries are.
+ "unset LD_LIBRARY_PATH\n"
(format #f "export GUILE_LOAD_PATH=\"~@?\"~%"
"~{~a~^:~}" (map scm pkgs))
(format #f "export GUILE_LOAD_COMPILED_PATH=\"~@?\"~%"