summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2015-10-04 19:49:24 +0300
committerAlex Kost <alezost@gmail.com>2015-10-12 11:00:59 +0300
commit0f6139b1b578b914e10898e7159cae9b32f1eff3 (patch)
tree430b86934aadd34868687606d47fc16854050c67 /gnu/packages/game-development.scm
parentad8b83bda052a12077d5da4c3c9b3d3d0911025a (diff)
downloadguix-patches-0f6139b1b578b914e10898e7159cae9b32f1eff3.tar
guix-patches-0f6139b1b578b914e10898e7159cae9b32f1eff3.tar.gz
gnu: Add physfs.
* gnu/packages/game-development.scm (physfs): New variable.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index e8efc2c5a3..fcebf2b548 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Julian Graham <joolean@gmail.com>
;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015 Alex Kost <alezost@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -27,6 +28,7 @@
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
#:use-module (gnu packages databases)
+ #:use-module (gnu packages doxygen)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnunet)
#:use-module (gnu packages guile)
@@ -225,3 +227,36 @@ Originally created for use in video game prototypes, it can generate random
sounds from presets such as \"explosion\" or \"powerup\".")
(home-page "http://www.drpetter.se/project_sfxr.html")
(license license:expat)))
+
+(define-public physfs
+ (package
+ (name "physfs")
+ (version "2.0.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://icculus.org/physfs/downloads/physfs-"
+ version ".tar.bz2"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0sbbyqzqhyf0g68fcvvv20n3928j0x6ik1njmhn1yigvq2bj11na"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:tests? #f)) ; no check target
+ (inputs
+ `(("zlib" ,zlib)))
+ (native-inputs
+ `(("doxygen" ,doxygen)))
+ (home-page "http://icculus.org/physfs")
+ (synopsis "File system abstraction library")
+ (description
+ "PhysicsFS is a library to provide abstract access to various archives.
+It is intended for use in video games. For security, no file writing done
+through the PhysicsFS API can leave a defined @emph{write directory}. For
+file reading, a @emph{search path} with archives and directories is defined,
+and it becomes a single, transparent hierarchical file system. So archive
+files can be accessed in the same way as you access files directly on a disk,
+and it makes it easy to ship a new archive that will override a previous
+archive on a per-file basis.")
+ (license license:zlib)))