summaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-11-20 22:23:26 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-20 23:11:44 +0100
commitc34bb6b310ec17bfa4cd9f412a0c44b419ce8f75 (patch)
treee239d4cfa69d18c054dd8787c7f80c8125b05558 /gnu/packages/game-development.scm
parentc51667d52ed40b70cd15ff890141bff98f5e0d9a (diff)
downloadguix-patches-c34bb6b310ec17bfa4cd9f412a0c44b419ce8f75.tar
guix-patches-c34bb6b310ec17bfa4cd9f412a0c44b419ce8f75.tar.gz
gnu: grafx2: Add 'file-name' field to source.
Without a file name ending in ".tgz" (or similar), the 'unpack' phase wouldn't extract it (as implemented in commit cfcead2e515c0dae02127e5a76496463898be6b6). * gnu/packages/game-development.scm (grafx2)[source]: Add 'file-name' field.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 9410921766..fd504b1a6e 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1608,6 +1608,7 @@ also comes with a built-in image and sound editor.")
(method url-fetch)
;; XXX: There is no URL that contains the version. :(
(uri "http://pulkomandy.tk/projects/GrafX2/downloads/21")
+ (file-name (string-append "grafx2-" version ".tgz"))
(sha256
(base32
"0svsy6rqmdj11b400c242i2ixihyz0hds0dgicqz6g6dcgmcl62q"))))