summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-08-22 17:18:01 +0800
committer宋文武 <iyzsong@gmail.com>2015-08-22 17:18:01 +0800
commit83a2e492044b4bf843f25f890c29af6640632c3a (patch)
treedc80b6e2ff2b113edb8ff937ae652f3ba4cec14e /gnu/packages/freedesktop.scm
parent86aff7912c6a3e904f7b904a441c3339a3c300c1 (diff)
downloadguix-patches-83a2e492044b4bf843f25f890c29af6640632c3a.tar
guix-patches-83a2e492044b4bf843f25f890c29af6640632c3a.tar.gz
gnu: Add accountsservice.
* gnu/packages/freedesktop.scm (accountsservice): New variable.
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index cbf26dc259..d47766835f 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -372,3 +372,42 @@ the udisksd(8) daemon via the name org.freedesktop.UDisks2 on the system
message bus.")
;; The dynamic library are under LGPLv2+, others are GPLv2+.
(license (list license:gpl2+ license:lgpl2.0+))))
+
+(define-public accountsservice
+ (package
+ (name "accountsservice")
+ (version "0.6.40")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.freedesktop.org/software/"
+ name "/" name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0ayb3y3l25dmwxlh9g071h02mphjfbkvi2k5f635bayb01k7akzh"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; XXX: tests require DocBook 4.1.2
+ #:configure-flags
+ '("--localstatedir=/var")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before
+ 'configure 'pre-configure
+ (lambda _
+ ;; Don't try to create /var/lib/AccoutsService.
+ (substitute* "src/Makefile.in"
+ (("\\$\\(MKDIR_P\\).*/lib/AccountsService.*") "true")))))))
+ (native-inputs
+ `(("glib:bin" ,glib "bin") ; for gdbus-codegen, etc.
+ ("gobject-introspection" ,gobject-introspection)
+ ("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("polkit" ,polkit)))
+ (home-page "http://www.freedesktop.org/wiki/Software/AccountsService/")
+ (synopsis "D-Bus interface for user account query and manipulation")
+ (description
+ "The AccountService project provides a set of D-Bus interfaces for querying
+and manipulating user account information and an implementation of these
+interfaces, based on the useradd, usermod and userdel commands.")
+ (license license:gpl3+)))