summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-09-24 19:18:35 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-09-24 19:18:35 +0200
commitffcff272728e750c62acbbf8322c2ad35d69ad81 (patch)
treebdab0ab0d8e0ede962fcd0f9a5474f67bb9ed682 /gnu/packages/freedesktop.scm
parent6baf1b72057ccda6e491596ad3715c4f555e6a69 (diff)
parent030030f4416b54285dcdd58bddb863c0e6bda4c4 (diff)
downloadguix-patches-ffcff272728e750c62acbbf8322c2ad35d69ad81.tar
guix-patches-ffcff272728e750c62acbbf8322c2ad35d69ad81.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index b9a2b4e895..950961ee9f 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2015, 2017 Andy Wingo <wingo@pobox.com>
;;; Copyright © 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
@@ -366,7 +366,10 @@ manager for the current system.")
(substitute* "test/test-icon.py"
(("/usr/share/icons/hicolor/index.theme")
(string-append (assoc-ref inputs "hicolor-icon-theme")
- "/share/icons/hicolor/index.theme")))
+ "/share/icons/hicolor/index.theme"))
+ ;; FIXME: This test fails because the theme contains the unknown
+ ;; key "Scale".
+ (("theme.validate\\(\\)") "#"))
;; One test fails with:
;; AssertionError: 'x-apple-ios-png' != 'png'