summaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-05 00:27:45 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:27 -0400
commitb93a63d4a08e2f0689d79da3879a9bc4ab17c69d (patch)
tree883e3978757c9037181ef321075118efacc691f9 /gnu/packages/fontutils.scm
parente3d1e821f9be2db1b4a77c8b06f3fbf2b6259481 (diff)
downloadguix-patches-b93a63d4a08e2f0689d79da3879a9bc4ab17c69d.tar
guix-patches-b93a63d4a08e2f0689d79da3879a9bc4ab17c69d.tar.gz
gnu: Add python-cu2qu.
* gnu/packages/fontutils.scm (python-cu2qu): New variable.
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 59b4f8075b..20a03463e6 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -133,6 +133,33 @@ files (OTF, TTF) and WOFF and WOFF2 font files, validating them and sanitizing
them as it goes.")
(license license:bsd-3)))
+(define-public python-cu2qu
+ (package
+ (name "python-cu2qu")
+ (version "1.6.7.post1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "cu2qu" version ".zip"))
+ (sha256
+ (base32 "1x762r7bf39g6aivfvrmq00h6f07abvs9x1xm0fz8l81vq8jz64c"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-fonttools-full))
+ (native-inputs
+ (list python-cython
+ python-defcon
+ python-pytest
+ python-pytest-runner
+ python-setuptools-scm
+ unzip))
+ (home-page "https://github.com/googlefonts/cu2qu")
+ (synopsis "Cubic-to-quadratic bezier curve conversion")
+ (description "This library provides functions which take in @acronym{UFO,
+Unified Font Object} objects (such as Defcon Fonts or Robofab RFonts) and
+converts any cubic curves to quadratic. The most useful function is probably
+@code{fonts_to_quadratic}.")
+ (license license:asl2.0)))
+
(define-public python-fontmath
(package
(name "python-fontmath")