summaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 17:33:55 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:52:28 -0400
commit910ce808850323f1cfbbcbbbf133705bf1149d98 (patch)
tree94c93d0c5bbaa2b529146d9e2beb404999f924be /gnu/packages/fontutils.scm
parentc9a21c421641562a9a77a880eb118e4dc4675f7f (diff)
downloadguix-patches-910ce808850323f1cfbbcbbbf133705bf1149d98.tar
guix-patches-910ce808850323f1cfbbcbbbf133705bf1149d98.tar.gz
gnu: nototools: Update to 0.2.16.
* gnu/packages/fontutils.scm (nototools): Update to 0.2.16. [arguments]: Remove python argument. [phases]: New argument. [native-inputs]: New field. [propagated-inputs]: Remove python2-booleanoperations, python2-defcon, python2-fonttools, python2-pillow, python2-pyclipper, and python2-ufolib. Add python-afdko.
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm28
1 files changed, 16 insertions, 12 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 444d1635cb..7c03109be5 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -1525,27 +1525,31 @@ UFO3 as described by the UFO font format.")
(define-public nototools
(package
(name "nototools")
- (version "20170925")
+ (version "0.2.16")
(source
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/googlei18n/nototools")
- (commit "v2017-09-25-tooling-for-phase3-update")))
+ (url "https://github.com/googlefonts/nototools")
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "03nzvcvwmrhfrcjhg218q2f3hfrm3vlivp4rk19sc397kh3hisiz"))))
+ "14rrdamkmhrykff8ln07fq9cm8zwj3k113lzwjcy0lgz23g51jyl"))))
(build-system python-build-system)
(arguments
- `(#:python ,python-2))
- (propagated-inputs
- (list python2-booleanoperations
- python2-defcon
- python2-fonttools
- python2-pillow
- python2-pyclipper
- python2-ufolib))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'pretend-version
+ (lambda _
+ (setenv "SETUPTOOLS_SCM_PRETEND_VERSION" #$version)))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (with-directory-excursion "tests"
+ (invoke "./run_tests")))))))
+ (native-inputs (list python-setuptools-scm))
+ (propagated-inputs (list python-afdko))
(home-page "https://github.com/googlei18n/nototools")
(synopsis "Noto fonts support tools and scripts")
(description