summaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-04-04 18:48:24 +0200
committerAndreas Enge <andreas@enge.fr>2013-04-04 18:49:28 +0200
commit6be960c7f7f8538024f5807dcd5b6a8a7562baf1 (patch)
tree05a6712b7e8aa0fe2b4314767dc0219e85ea695e /gnu/packages/fontutils.scm
parent9be8d7c8cb1b1ee4d1f3ba7360320527199b4a0d (diff)
parent8dc5d0cf7e18ee423c73087570c6b50d215ae216 (diff)
downloadguix-patches-6be960c7f7f8538024f5807dcd5b6a8a7562baf1.tar
guix-patches-6be960c7f7f8538024f5807dcd5b6a8a7562baf1.tar.gz
Merge branch 'xorg' into core-updates
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 551d4ac167..14f8250357 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -38,6 +38,20 @@
(sha256 (base32
"0gpcz6swir64kp0dk3rwgqqkmf48b90dqgczdmznjjryhrahx9r9"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (alist-replace
+ 'install
+ (lambda* (#:key outputs #:allow-other-keys #:rest args)
+ (let ((install (assoc-ref %standard-phases 'install))
+ (include (string-append (assoc-ref outputs "out") "/include")))
+ (apply install args)
+ ;; Unravel one directory, since ft2build.h includes directly from
+ ;; freetype/, not freetype2/freetype; this is announced in the file
+ ;; to be changed in a future release.
+ (symlink (string-append include "/freetype2/freetype")
+ (string-append include "/freetype"))))
+ %standard-phases)))
(synopsis "Freetype, a library to render fonts")
(description
"Freetype is a library that can be used by applications to access the