summaryrefslogtreecommitdiff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-01 17:33:00 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-01 17:33:00 +0100
commit19464173bafdc42adfc8dd7277c491c40ddef66b (patch)
tree2842e0f62404e307ef0432f2ccce8b5ce60ab392 /gnu/packages/fonts.scm
parent85ef07c4b278200db7c396f4021146916588f2fb (diff)
parent81bb55459af85c408977470673e718ed1c0d6a25 (diff)
downloadguix-patches-19464173bafdc42adfc8dd7277c491c40ddef66b.tar
guix-patches-19464173bafdc42adfc8dd7277c491c40ddef66b.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm22
1 files changed, 12 insertions, 10 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index b38816f664..6c562d977d 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -199,15 +199,15 @@ sans-serif designed for on-screen reading. It is used by GNOME@tie{}3.")
(define-public font-lato
(package
(name "font-lato")
- (version "2.010")
+ (version "2.010") ; also update description
(source (origin
(method url-fetch/zipbomb)
- (uri (string-append "http://www.latofonts.com/download/Lato2OFL.zip"))
+ (uri (string-append "https://www.latofonts.com/download/Lato2OFL.zip"))
(sha256
(base32
"1f5540g0ja1nx3ddd3ywn77xc81ssrxpq8n3gyb9sabyq2b4xda2"))))
(build-system font-build-system)
- (home-page "http://www.latofonts.com/lato-free-fonts/")
+ (home-page "https://www.latofonts.com/lato-free-fonts/")
(synopsis "Lato sans-serif typeface")
(description
"Lato is a sanserif typeface family. It covers over 3000 glyphs per style.
@@ -824,7 +824,7 @@ glyph designs, not just an added slant.")
(synopsis "Typeface designed for source code")
(description
"Hack is designed to be a workhorse typeface for code. It expands upon
-the Bitstream Vera & DejaVu projects, provides 1561 glyphs, and includes
+the Bitstream Vera & DejaVu projects, provides over 1,500 glyphs, and includes
Powerline support.")
(license
;; See https://github.com/source-foundry/Hack/issues/271 for details.
@@ -971,17 +971,19 @@ correct spacing.")
(define-public font-awesome
(package
(name "font-awesome")
- (version "5.7.2")
+ ;; XXX The build scripts of version 5 are not freely licensed and
+ ;; so we have to stick with version 4 for now:
+ ;; <https://bugs.gnu.org/32916>
+ (version "4.7.0")
(source (origin
(method url-fetch)
- (uri (string-append
- "https://use.fontawesome.com/releases/v" version "/"
- "fontawesome-free-" version "-desktop.zip"))
+ (uri (string-append "http://fontawesome.io/assets/"
+ name "-" version ".zip"))
(sha256
(base32
- "0v8nfyjkzgi33i5arpjqzs16mgh2hx02sf906b8a9k1k7yfqpbgs"))))
+ "1m1rfwm4sjkv10j3xd2dhwk286a5912b2zgvc692cmxi5gxs68jf"))))
(build-system font-build-system)
- (home-page "https://fontawesome.com")
+ (home-page "http://fontawesome.io")
(synopsis "Font that contains a rich iconset")
(description
"Font Awesome is a full suite of pictographic icons for easy scalable