summaryrefslogtreecommitdiff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-06-21 21:40:51 +0200
committerJulien Lepiller <julien@lepiller.eu>2020-06-21 21:43:07 +0200
commit3f3c61b8d558f8b35d028df7effa23fd7b67c914 (patch)
tree67e0abd6e42049c6813297a363f64b80f249c600 /gnu/packages/fonts.scm
parentdbadca9ac72ae2a3e228f3dfe4aaacc3db5fbeed (diff)
downloadguix-patches-3f3c61b8d558f8b35d028df7effa23fd7b67c914.tar
guix-patches-3f3c61b8d558f8b35d028df7effa23fd7b67c914.tar.gz
gnu: Add font-mplus-testflight.
* gnu/packages/fonts.scm (font-mplus-testflight): New variable.
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 643653f3f5..5a913441e9 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -1873,3 +1873,27 @@ dictionary headwords and picture books. This font reduces the thickness
differences in characters compared to other antique fonts.")
(license (list license:ipa
(license:non-copyleft "mplus-TESTFLIGHT-057/LICENSE_E")))))
+
+(define-public font-mplus-testflight
+ (package
+ (name "font-mplus-testflight")
+ (version "063a")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://osdn.net/frs/redir.php?"
+ "m=gigenet&f=mplus-fonts%2F62344%2Fmplus-TESTFLIGHT-"
+ version ".tar.xz"))
+ (file-name (string-append name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0yfx9i77638yrgclnwwl4af79ri3vifi1nslwi6mgzva9cxrgss4"))))
+ (build-system font-build-system)
+ (home-page "https://mplus-fonts.osdn.jp/index.html")
+ (synopsis "Japanese font collection")
+ (description "M+ is a collection of Japanese fonts with all Latin glyph
+sets, with Basic Latin, Latin-1 Supplement, Latin Extended-A, and IPA
+Extensions. In addition to European letters used in many Western European
+languages, it contains Japanese characters, including Kana glyphs and more
+than 5,300 Kanji glyphs, as well major international phonetic symbols,
+operators and special symbols.")
+ (license (license:non-copyleft "file:///LICENSE_E"))))