summaryrefslogtreecommitdiff
path: root/gnu/packages/firmware.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-13 13:39:33 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-10 00:06:13 -0400
commit8dd6c2dee88e8adc143ac27b36c182e31a00c8b8 (patch)
tree4091cbe10207c186c9704165479b005a4c8daed0 /gnu/packages/firmware.scm
parent2f0e21e9fab05945d60bc133a1e0bcc1f4a2c588 (diff)
downloadguix-patches-8dd6c2dee88e8adc143ac27b36c182e31a00c8b8.tar
guix-patches-8dd6c2dee88e8adc143ac27b36c182e31a00c8b8.tar.gz
gnu: Add qmk-udev-rules.
* gnu/packages/firmware.scm (qmk-udev-rules): New variable.
Diffstat (limited to 'gnu/packages/firmware.scm')
-rw-r--r--gnu/packages/firmware.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index d07b329d26..054b674b23 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -1447,3 +1447,21 @@ shortcuts and can be interpreted by your window managher. This layout only
makes use of the 42 keys that the Atreus also has for the main functionality.
See the @file{keyboards/atreus/keymaps/dvorak_42_key/keymap.c} source file for
the keymap definition."))
+
+(define-public qmk-udev-rules
+ (package
+ (inherit qmk-firmware-ergodox-ez-default)
+ (name "qmk-udev-rules")
+ (build-system copy-build-system)
+ (arguments
+ '(#:install-plan '(("./util/udev" "lib/udev/rules.d"
+ #:include-regexp ("rules$")))))
+ (native-inputs '())
+ (inputs '())
+ (propagated-inputs '())
+ (synopsis "Udev rules for QMK Firmware")
+ (description
+ "This package provides a set of udev rules to specify the proper
+privileges for flashing QMK compatible devices without needing root. The
+rules require the group @code{plugdev} to be added to each user that needs
+this.")))