summaryrefslogtreecommitdiff
path: root/gnu/packages/firmware.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-02-07 13:31:18 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-02-08 09:26:19 +0200
commitb84a6cd08c7b41653601de0e9d8359e7db76c24c (patch)
tree4d8bd0c7d2b3d02ab831abf448ce4be403a3c3b4 /gnu/packages/firmware.scm
parent6598e4c56bb94c5032245e54d4f8aeee7fc94f31 (diff)
downloadguix-patches-b84a6cd08c7b41653601de0e9d8359e7db76c24c.tar
guix-patches-b84a6cd08c7b41653601de0e9d8359e7db76c24c.tar.gz
gnu: openbios-qemu-ppc: Don't build for a specific target.
* gnu/packages/firmware.scm (openbios-qemu-ppc)[arguments]: Set target to #f since we're producing a firmware file and not a binary.
Diffstat (limited to 'gnu/packages/firmware.scm')
-rw-r--r--gnu/packages/firmware.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index fea7d37923..080aaed55b 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -419,6 +419,8 @@ provide OpenFirmware functionality on top of an already running system.")
(%current-target-system)))
"armhf-linux"
system))
+ ;; No need to cross-compile, package produces reproducible firmware.
+ ((#:target _ #f) #f)
((#:phases phases)
#~(modify-phases #$phases
(add-after 'install 'rename-executable