summaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-17 15:37:50 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-19 09:31:30 +0000
commit4fd0c88dc61743cde210150e84231593db4bc7a1 (patch)
tree083160a8988b079155177b1ffcde66bb17d0d8ad /gnu/packages/finance.scm
parentc8fdd007f9430be7310b37153c92252b78bdac17 (diff)
downloadguix-patches-4fd0c88dc61743cde210150e84231593db4bc7a1.tar
guix-patches-4fd0c88dc61743cde210150e84231593db4bc7a1.tar.gz
gnu: beancount: Enable sanity check.
Inputs were swapped to propagated-inputs to allow other packages depending on `beancount` to pass sanity check. * gnu/packages/finance.scm (beancount) [arguments] <#:phases>: Remove 'ignore-googleapis phase. Add 'relax-requirements phase, disabling check for "pdfminer2". [propagated-inputs]: Add python-google-api-client and python-google-auth-oauthlib. Change-Id: I15af4cd9cdbf5d522b9c5570e3ba60ad4d29e231
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 32c507cd85..9d9ba26b9e 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1980,18 +1980,18 @@ that allows you to run services and through them access the Bitcoin Cash network
#:tests? #f ; Says test is missing, not sure why
#:phases
#~(modify-phases %standard-phases
- ;; Not importing the googleapis package for now
- (add-after 'unpack 'ignore-googleapis
+ (add-after 'unpack 'relax-requirements
(lambda _
(substitute* "setup.py"
- (("'google-api-python-client',") ""))))
- ;; No module named 'google_auth_oauthlib'
- (delete 'sanity-check))))
- (inputs
+ ;; Use compatible fork, and do not fail during sanity check.
+ (("\"pdfminer2\",") "")))))))
+ (propagated-inputs
(list python-beautifulsoup4
python-bottle
python-chardet
python-dateutil
+ python-google-api-client
+ python-google-auth-oauthlib
python-lxml
python-magic
python-ply