summaryrefslogtreecommitdiff
path: root/gnu/packages/file-systems.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-06-19 17:38:47 +0200
committerMarius Bakke <marius@gnu.org>2021-06-19 17:38:47 +0200
commit6f9a80b331ae41d142a49fbeb94b90ee587b6155 (patch)
tree2da042a6ccf5368c73d6e3d54c2ee02a62d284e4 /gnu/packages/file-systems.scm
parent6500c9a5b364616e38a7e03aa4516fc2d7cee876 (diff)
parentdece03e2b98fc1c2428c2448ce5792f813eb79bf (diff)
downloadguix-patches-6f9a80b331ae41d142a49fbeb94b90ee587b6155.tar
guix-patches-6f9a80b331ae41d142a49fbeb94b90ee587b6155.tar.gz
Merge branch 'master' into core-updates
Note: this merge actually changes the 'curl' and 'python-attrs' derivations, as part of solving caf4a7a2770ef4d05a6e18f40d602e51da749ddc and 12964df69a99de6190422c752fef65ef813f3b6b respectively. 4604d43c0e (gnu: gnutls@3.6.16: Fix cross-compilation.) was ignored because it cannot currently be tested. Conflicts: gnu/local.mk gnu/packages/aidc.scm gnu/packages/boost.scm gnu/packages/curl.scm gnu/packages/nettle.scm gnu/packages/networking.scm gnu/packages/python-xyz.scm gnu/packages/tls.scm
Diffstat (limited to 'gnu/packages/file-systems.scm')
-rw-r--r--gnu/packages/file-systems.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 4d6dc89fd9..e2335b8a86 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -345,8 +345,8 @@ from a mounted file system.")
(license license:gpl2+)))
(define-public bcachefs-tools
- (let ((commit "7942d5cab4f02bd4db12ee26a792a6012b4d7b07")
- (revision "7"))
+ (let ((commit "fe1bb39aa52d9140981ba1e96f3c95ddf14006ce")
+ (revision "8"))
(package
(name "bcachefs-tools")
(version (git-version "0.1" revision commit))
@@ -358,7 +358,7 @@ from a mounted file system.")
(commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "0k8cnkjm0v9xs7w02sj5151y6h8bj0gxmc3fq8js1wzx6wip9w96"))))
+ (base32 "1ks6w2v76pfpp70cv1d6znxaw1g5alz1v6hf8z9gvj15r94vgpwz"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags
@@ -576,6 +576,7 @@ single file can be mounted.")
(sha256
(base32 "0kbsy2sk1jv4m82rxyl25gwrlkzvl3hzdga9gshkxkhm83v1aji4"))
(patches (search-patches "jfsutils-add-sysmacros.patch"
+ "jfsutils-gcc-compat.patch"
"jfsutils-include-systypes.patch"))))
(build-system gnu-build-system)
(inputs
@@ -860,7 +861,7 @@ A simple @command{eatmydata} script is included that does this for you.")
(define-public libnfs
(package
(name "libnfs")
- (version "3.0.0")
+ (version "4.0.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -869,7 +870,7 @@ A simple @command{eatmydata} script is included that does this for you.")
(file-name (git-file-name name version))
(sha256
(base32
- "115p55y2cbs92z5lmcnjx1v29lwinpgq4sha9v1kq1vd8674h404"))))
+ "0i27wd4zvhjz7620q043p4d4mkx8zv2yz9adm1byin47dynahyda"))))
(build-system gnu-build-system)
(home-page "https://github.com/sahlberg/libnfs")
(native-inputs