summaryrefslogtreecommitdiff
path: root/gnu/packages/file-systems.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-21 00:48:04 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-21 01:39:01 +0200
commitf743c432cc04aad81e09181376560bd1bddfb5f2 (patch)
tree9ea923cc05a7554bce4561f143b0bcd80296d7eb /gnu/packages/file-systems.scm
parent5c8c7f74e63aee19169bba8e6d79e4557f1d3957 (diff)
downloadguix-patches-f743c432cc04aad81e09181376560bd1bddfb5f2.tar
guix-patches-f743c432cc04aad81e09181376560bd1bddfb5f2.tar.gz
gnu: autofs: Update to 5.1.8.
* gnu/packages/file-systems.scm (autofs): Update to 5.1.8. [arguments]: Don't explicitly return #t from phases.
Diffstat (limited to 'gnu/packages/file-systems.scm')
-rw-r--r--gnu/packages/file-systems.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 5f0c848e4c..a22e107336 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -88,7 +88,7 @@
(define-public autofs
(package
(name "autofs")
- (version "5.1.7")
+ (version "5.1.8")
(source
(origin
(method url-fetch)
@@ -96,7 +96,7 @@
"v" (version-major version) "/"
"autofs-" version ".tar.xz"))
(sha256
- (base32 "1myfz6a3wj2c4j9h5g44zj796fdi82jhp1s92w2hg6xp2632csx3"))))
+ (base32 "1zf0fgf6kr9amxq5amlgsp1v13sizwl3wvx2xl7b4r2nhmci0gdk"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -118,8 +118,7 @@
(lambda _
(substitute* "configure"
(("^searchpath=\".*\"")
- "searchpath=\"$PATH\""))
- #t))
+ "searchpath=\"$PATH\""))))
(add-before 'configure 'fix-rpath
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
@@ -132,8 +131,7 @@
(lambda _
(substitute* "modules/Makefile"
(("ln -fs lookup_yp.so" match)
- (string-append "# " match)))
- #t)))))
+ (string-append "# " match))))))))
(native-inputs
`(("bison" ,bison)
("flex" ,flex)