summaryrefslogtreecommitdiff
path: root/gnu/packages/fcitx.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-04-30 21:49:23 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-05-01 00:30:25 +0300
commit23552fb2fbcb78757e8b563de9466831f6386105 (patch)
tree133c0255d06f764d9d691a2e90cc89247e36564c /gnu/packages/fcitx.scm
parent1ab846181f0d068f071962c596ac4173761f5c6e (diff)
downloadguix-patches-23552fb2fbcb78757e8b563de9466831f6386105.tar
guix-patches-23552fb2fbcb78757e8b563de9466831f6386105.tar.gz
gnu: presage: Update outdated config scripts.
* gnu/packages/fcitx.scm (presage)[arguments]: Add a phase to update the outdated config scripts. [native-inputs]: Add config.
Diffstat (limited to 'gnu/packages/fcitx.scm')
-rw-r--r--gnu/packages/fcitx.scm16
1 files changed, 13 insertions, 3 deletions
diff --git a/gnu/packages/fcitx.scm b/gnu/packages/fcitx.scm
index fcd8acb721..b21b269926 100644
--- a/gnu/packages/fcitx.scm
+++ b/gnu/packages/fcitx.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2023 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -28,6 +29,7 @@
#:use-module (guix build-system cmake)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system qt)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages check)
#:use-module (gnu packages documentation)
#:use-module (gnu packages enchant)
@@ -128,10 +130,18 @@
(mkdir-p (string-append doc "/share/presage"))
(rename-file
(string-append out "/share/presage/html")
- (string-append doc "/share/presage/html"))
- #t))))))
+ (string-append doc "/share/presage/html")))))
+ (add-after 'unpack 'update-config-scripts
+ (lambda* (#:key native-inputs inputs #:allow-other-keys)
+ (for-each (lambda (file)
+ (install-file
+ (search-input-file
+ (or native-inputs inputs)
+ (string-append "/bin/" file)) "."))
+ '("config.guess" "config.sub")))))))
(native-inputs
- `(("dot" ,graphviz)
+ `(("config" ,config)
+ ("dot" ,graphviz)
("doxygen" ,doxygen)
("gettext" ,gettext-minimal)
("glib:bin" ,glib "bin")