summaryrefslogtreecommitdiff
path: root/gnu/packages/erlang.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-10-06 10:50:25 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-10-07 22:35:30 +0200
commitf86f7e24b39928247729020df0134e2e1c4cde62 (patch)
treec8e4db59f406e82b8f709bec9e660d7aa64d716c /gnu/packages/erlang.scm
parentfd4a80a46c535e7911559fe0d03ad3855457927e (diff)
downloadguix-patches-f86f7e24b39928247729020df0134e2e1c4cde62.tar
guix-patches-f86f7e24b39928247729020df0134e2e1c4cde62.tar.gz
gnu: Add erlang-covertool.
* gnu/packages/erlang.scm (erlang-covertool): New variable.
Diffstat (limited to 'gnu/packages/erlang.scm')
-rw-r--r--gnu/packages/erlang.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index b9c7424441..13235c6f1f 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -301,6 +301,26 @@ Mozilla's canonical set.")
printing extending the io:format syntax to add colours.")
(license license:expat)))
+(define-public erlang-covertool
+ (package
+ (name "erlang-covertool")
+ (version "2.0.4")
+ (source
+ (origin
+ (method hexpm-fetch)
+ (uri (hexpm-uri "covertool" version))
+ (sha256
+ (base32 "10krv66nabzrgkz4k3gfp7zx1x9030vnkhc0n1f1chwzwf4sa6nx"))))
+ (build-system rebar3-build-system)
+ (home-page "https://github.com/covertool/covertool")
+ (synopsis "Convert Erlang cover data into Cobertura XML reports")
+ (description "This package provides a build tool and plugin to convert
+exported Erlang cover data sets into Cobertura XML reports, which can then be
+feed to the Jenkins Cobertura plug-in.
+
+On @emph{hex.pm}, this plugin was previously called @code{rebar_covertool}.")
+ (license license:bsd-2)))
+
(define-public erlang-cth-readable
(package
(name "erlang-cth-readable")