summaryrefslogtreecommitdiff
path: root/gnu/packages/enlightenment.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-01-06 21:28:42 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-01-06 21:35:03 +0200
commit57bf228b66ad14eb5a9165751ee9aeda1acc5b47 (patch)
treedecd6b46f5bd8f84e7e3cb27d5725bbc9c7e21ba /gnu/packages/enlightenment.scm
parentc24ffc3aae0f163062988f406bc26e854585a9a7 (diff)
downloadguix-patches-57bf228b66ad14eb5a9165751ee9aeda1acc5b47.tar
guix-patches-57bf228b66ad14eb5a9165751ee9aeda1acc5b47.tar.gz
gnu: terminology: Respect #:tests? flag.
* gnu/packages/enlightenment.scm (terminology)[arguments]: Adjust custom 'check phase to honor the #:tests? flag.
Diffstat (limited to 'gnu/packages/enlightenment.scm')
-rw-r--r--gnu/packages/enlightenment.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index 347b7ea9c6..bfb93d9534 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -235,11 +235,12 @@ removable devices or support for multimedia.")
;; FATAL: Cannot create run dir '/homeless-shelter/.run' - errno=2
(lambda _ (setenv "HOME" "/tmp")))
(replace 'check
- (lambda _
- (with-directory-excursion
- (string-append "../" ,name "-" ,version "/tests")
- (invoke "sh" "run_tests.sh" "--verbose"
- "-t" "../../build/src/bin/tytest"))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion
+ (string-append "../" ,name "-" ,version "/tests")
+ (invoke "sh" "run_tests.sh" "--verbose"
+ "-t" "../../build/src/bin/tytest")))))
(add-after 'install 'remove-test-binary
(lambda* (#:key outputs #:allow-other-keys)
;; This file is not meant to be installed.