summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-25 22:05:50 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-25 23:56:29 +0100
commit6a18f4c5dc6ee78e0b1f9ba757a3a70e0d9726d5 (patch)
tree625e0cfe64b0a8103c11ac82709a8f92c4a9e71f /gnu/packages/engineering.scm
parent4c76af04e014ca001ae97369c0f1100f9c1cdcbf (diff)
downloadguix-patches-6a18f4c5dc6ee78e0b1f9ba757a3a70e0d9726d5.tar
guix-patches-6a18f4c5dc6ee78e0b1f9ba757a3a70e0d9726d5.tar.gz
gnu: volk: Update to 2.4.0.
* gnu/packages/engineering.scm (volk): Update to 2.4.0. [source]: Clone recursively.
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 5a66d0a77c..99b1545b6d 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1077,16 +1077,17 @@ the 'showing the effect of'-style of operation.")
(define-public volk
(package
(name "volk")
- (version "2.3.0")
+ (version "2.4.0")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/gnuradio/volk")
- (commit (string-append "v" version))))
+ (commit (string-append "v" version))
+ (recursive? #t))) ; for cpu_features git submodule
(file-name (git-file-name name version))
(sha256
- (base32 "1jya1v1z1mq50n5fxhs755vcdjvwiv2iqjmycn2l1bx552vzh6cg"))))
+ (base32 "14y0988r5qi1h3yvkivx5ihccn8r15910lq30r8iy71ih190r5m9"))))
(build-system cmake-build-system)
(arguments
`(#:phases