summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2021-02-03 09:14:43 +0000
committerChristopher Baines <mail@cbaines.net>2021-02-03 09:57:35 +0000
commite740cc614096e768813280c718f9e96343ba41b3 (patch)
tree25ade70a5d408be80f62f19c6511172aab7dcce5 /gnu/packages/engineering.scm
parent1b9186828867e77af1f2ee6741063424f8256398 (diff)
parent63cf277bfacf282d2b19f00553745b2a9370eca0 (diff)
downloadguix-patches-e740cc614096e768813280c718f9e96343ba41b3.tar
guix-patches-e740cc614096e768813280c718f9e96343ba41b3.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm39
1 files changed, 30 insertions, 9 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index bcc6ddb284..7bbf732fc9 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -15,12 +15,12 @@
;;; Copyright © 2019 Steve Sprang <scs@stevesprang.com>
;;; Copyright © 2019 John Soo <jsoo1@asu.edu>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
-;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
+;;; Copyright © 2020,2021 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Ekaitz Zarraga <ekaitz@elenq.tech>
;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
-;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
-;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
+;;; Copyright © 2020, 2021 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020, 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -50,6 +50,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix build-system ant)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system emacs)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
#:use-module (guix build-system qt)
@@ -1214,14 +1215,14 @@ use on a given system.")
(define-public libredwg
(package
(name "libredwg")
- (version "0.11.1")
+ (version "0.12")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://gnu/libredwg/libredwg-"
version ".tar.xz"))
(sha256
- (base32 "1xx6y6ckm4mzqln8y8lqf5frcn2b32ypc0d0h9dzpz6363zh7pdn"))))
+ (base32 "0z5algzi3alq166885y0qyj2gnc7gc6vhnz7nw0kwc0d236p6md8"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--disable-bindings")))
@@ -1524,7 +1525,7 @@ bindings for Python, Java, OCaml and more.")
(define-public radare2
(package
(name "radare2")
- (version "4.4.0")
+ (version "5.0.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1532,7 +1533,7 @@ bindings for Python, Java, OCaml and more.")
(commit version)))
(sha256
(base32
- "0gwdnrnk7wdgkajp2qwg4fyplh7nsbmf01bzx07px6xmiscd9z2s"))
+ "0aa7c27kd0l55fy5qfvxqmakp4pz6240v3hn84095qmqkzcbs420"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
@@ -2367,7 +2368,7 @@ simulation.")
(define-public cutter
(package
(name "cutter")
- (version "1.10.3")
+ (version "1.12.0")
(source
(origin
(method git-fetch)
@@ -2376,7 +2377,7 @@ simulation.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0qj8jyij02nif4jpirl09ygwnv8a9zi3vkb5sf5s8mg7qwlpnvyk"))))
+ (base32 "0ljj3j3apbbw628n2nyrxpbnclixx20bqjxm0xwggqzz9vywsar0"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -2513,6 +2514,26 @@ full programmatic control over your models.")
(home-page "https://www.openscad.org/")
(license license:gpl2+)))
+(define-public emacs-scad-mode
+ (package
+ (inherit openscad)
+ (name "emacs-scad-mode")
+ (native-inputs '())
+ (inputs '())
+ (build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir-elisp
+ ;; Elisp directory is not in root of the source.
+ (lambda _
+ (chdir "contrib")
+ #t)))))
+ (synopsis "Emacs major mode for editing editing OpenSCAD code")
+ (description "@code{scad-mode} provides an Emacs major mode for editing
+OpenSCAD code. It supports syntax highlighting, indenting and refilling of
+comments.")))
+
(define-public freecad
(let ((commit-ref "7616153b3c31ace006169cdc2fdafab484498858")
(revision "1"))