summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-05-25 00:25:15 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-05-25 00:25:15 +0200
commit57df83e07d4b5e78d9a54c1a88d05b4a9ed65714 (patch)
tree76684e63965e9ad6e37d9d45bc3159e6c9782cd0 /gnu/packages/engineering.scm
parent43d9ed7792808638eabb43aa6133f1d6186c520b (diff)
parent136b7d81f0eb713783e9ea7cf7f260a2b6252dfd (diff)
downloadguix-patches-57df83e07d4b5e78d9a54c1a88d05b4a9ed65714.tar
guix-patches-57df83e07d4b5e78d9a54c1a88d05b4a9ed65714.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm26
1 files changed, 13 insertions, 13 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 78a9930802..9b0f00c7be 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -779,7 +779,7 @@ language.")
"-DKICAD_SCRIPTING=ON"
"-DKICAD_SCRIPTING_MODULES=ON"
"-DKICAD_SCRIPTING_WXPYTHON=ON"
- ;; Has to be set explicitely, as we don't have the wxPython
+ ;; Has to be set explicitly, as we don't have the wxPython
;; headers in the wxwidgets store item, but in wxPython.
(string-append "-DCMAKE_CXX_FLAGS=-I"
(assoc-ref %build-inputs "wxpython")
@@ -851,18 +851,18 @@ electrical diagrams), gerbview (viewing Gerber files) and others.")
(package
(name "kicad-library")
(version version)
- (source (origin
- (method url-fetch)
- (uri (string-append
- "http://downloads.kicad-pcb.org/libraries/kicad-library-"
- version ".tar.gz"))
- (sha256
- (base32
- "1azb7v1y3l6j329r9gg7f4zlg0wz8nh4s4i5i0l9s4yh9r6i9zmv"))))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://kicad-downloads.s3.cern.ch/libraries/kicad-library-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1azb7v1y3l6j329r9gg7f4zlg0wz8nh4s4i5i0l9s4yh9r6i9zmv"))))
(build-system cmake-build-system)
(arguments
`(#:out-of-source? #t
- #:tests? #f ; no tests
+ #:tests? #f ; no tests
#:phases
(modify-phases %standard-phases
(add-after 'install 'install-footprints ; from footprints tarball
@@ -882,14 +882,14 @@ electrical diagrams), gerbview (viewing Gerber files) and others.")
(fp-lib-table (string-append template-dir "/fp-lib-table")))
(delete-file fp-lib-table)
(copy-file (string-append fp-lib-table ".for-pretty")
- fp-lib-table))
+ fp-lib-table))
#t)))))
(native-search-paths
(list (search-path-specification
- (variable "KISYSMOD") ; footprint path
+ (variable "KISYSMOD") ; footprint path
(files '("share/kicad/modules")))
(search-path-specification
- (variable "KISYS3DMOD") ; 3D model path
+ (variable "KISYS3DMOD") ; 3D model path
(files '("share/kicad/modules/packages3d")))))
;; Kicad distributes footprints in a separate tarball.
(native-inputs