summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorLéo Le Bouter <lle-bout@zaclys.net>2021-03-10 22:22:04 +0100
committerLéo Le Bouter <lle-bout@zaclys.net>2021-03-10 22:22:04 +0100
commitb610e4b9a7d4423603cac1da4f16475fb1e03e83 (patch)
treef817e1289b33caa8f7d749e8fdfd98ab9f0dd2a3 /gnu/packages/engineering.scm
parent6c5d358cc25ca94d9c0c75a3a086e81b2d63d1b6 (diff)
downloadguix-patches-b610e4b9a7d4423603cac1da4f16475fb1e03e83.tar
guix-patches-b610e4b9a7d4423603cac1da4f16475fb1e03e83.tar.gz
gnu: lib3mf: Update to 2.1.1 [security fixes].
Non-exhaustively, fixes CVE-2021-21772. * gnu/packages/engineering.scm (lib3mf): Update to 2.1.1. [arguments]<#:phases>: Remove. [arguments]<#:configure-flags>: Do not use zlib, libzip, gtest and libressl vendored sources. [native-inputs]: Remove googletest-source, add googletest and pkg-config. [inputs]: Add libzip, libressl and zlib.
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm25
1 files changed, 13 insertions, 12 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index f560a15aa9..b4ffc5f477 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2458,7 +2458,7 @@ engineers for reverse engineers.")
(define-public lib3mf
(package
(name "lib3mf")
- (version "1.8.1")
+ (version "2.1.1")
(source
(origin
(method git-fetch)
@@ -2467,20 +2467,21 @@ engineers for reverse engineers.")
(file-name (git-file-name name version))
(sha256
(base32
- "11wpk6n9ga2p57h1dcrp37w77mii0r7r6mlrgmykf7rvii1rzgqd"))))
+ "1417xlxc1y5jnipixhbjfrrjgkrprbbraj8647sff9051m3hpxc3"))))
(build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags (list "-DUSE_INCLUDED_ZLIB=0"
+ "-DUSE_INCLUDED_LIBZIP=0"
+ "-DUSE_INCLUDED_GTEST=0"
+ "-DUSE_INCLUDED_SSL=0")))
(native-inputs
- `(("googletest-source" ,(package-source googletest))))
+ `(("googletest" ,googletest)
+ ("pkg-config" ,pkg-config)))
(inputs
- `(("libuuid" ,util-linux "lib")))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'unpack-googletest
- (lambda* (#:key inputs #:allow-other-keys)
- (copy-recursively (assoc-ref inputs "googletest-source")
- "UnitTests/googletest")
- #t)))))
+ `(("libuuid" ,util-linux "lib")
+ ("libzip" ,libzip)
+ ("libressl" ,libressl)
+ ("zlib" ,zlib)))
(synopsis "Implementation of the 3D Manufacturing Format (3MF) file standard")
(description
"Lib3MF is a C++ implementation of the 3D Manufacturing Format (3MF) file