summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-09-11 22:41:50 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-09-21 14:03:42 +0000
commitfa6a1f52b2a1e55770ac073884cb7146749d3e63 (patch)
tree5d259d0fa494ddc67a547798e134e773f75dc8ba /gnu/packages/engineering.scm
parent1c57703a161dbefe95f2a456bb263c9a913675ed (diff)
downloadguix-patches-fa6a1f52b2a1e55770ac073884cb7146749d3e63.tar
guix-patches-fa6a1f52b2a1e55770ac073884cb7146749d3e63.tar.gz
gnu: libngspice: Update to 35.
* gnu/packages/engineering.scm (libngspice): Update to 35. [arguments]<#:phases>: Rename 'delete-scripts-and-config to 'delete-scripts and don't try to delete config.h because that file was removed in this version. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm13
1 files changed, 4 insertions, 9 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 300fc04ce5..073d524955 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1709,7 +1709,7 @@ high-performance parallel differential evolution (DE) optimization algorithm.")
;; See <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=27344#236>.
(package
(name "libngspice")
- (version "34")
+ (version "35")
(source
(origin
(method url-fetch)
@@ -1720,7 +1720,7 @@ high-performance parallel differential evolution (DE) optimization algorithm.")
"old-releases/" version
"/ngspice-" version ".tar.gz")))
(sha256
- (base32 "1dfpkgkwmgwhq8dnbb8dh28cfap6rw0yywkhmxr4jxclcvygyqr2"))))
+ (base32 "1v3ra9p2sc6ash1bbjm6i4i3dd6ymxjgnyha7z5rlmyvfv1gbdy1"))))
(build-system gnu-build-system)
(arguments
`(;; No tests for libngspice exist.
@@ -1737,16 +1737,11 @@ high-performance parallel differential evolution (DE) optimization algorithm.")
(substitute* "man/man1/Makefile.in"
(("^man_MANS = ngspice\\.1 ngnutmeg\\.1 ngsconvert\\.1 ngmultidec\\.1")
"man_MANS = "))))
- (add-after 'install 'delete-scripts-and-config
+ (add-after 'install 'delete-scripts
(lambda* (#:key outputs #:allow-other-keys)
(delete-file-recursively
(string-append (assoc-ref outputs "out")
- "/share/ngspice/scripts"))
- ;; This file is autogenerated by the configure script and should
- ;; not be distributed. It could be removed in ngspice 35. See
- ;; https://bugs.archlinux.org/task/70569 for reference.
- (delete-file (string-append (assoc-ref outputs "out")
- "/include/config.h")))))
+ "/share/ngspice/scripts")))))
#:configure-flags
(list "--enable-openmp"
"--enable-ciderlib"