summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-07-18 16:05:21 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-18 19:50:01 +0200
commit0e47fcced442d8e7c1b05184fdc1c14f10ed04ec (patch)
tree4ae844bc0ec3c670f8697bdc24362c122fa718ad /gnu/packages/engineering.scm
parente4b70bc55a538569465bcedee19d1f2607308e65 (diff)
parent8b1bde7bb3936a64244824500ffe60f123704437 (diff)
downloadguix-patches-0e47fcced442d8e7c1b05184fdc1c14f10ed04ec.tar
guix-patches-0e47fcced442d8e7c1b05184fdc1c14f10ed04ec.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm46
1 files changed, 35 insertions, 11 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index c02d07fba1..aa74d691c7 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1046,23 +1046,17 @@ translations for KiCad.")
(build-system cmake-build-system)
(arguments
`(#:configure-flags (list "-DBUILD_FORMATS=html")
+ #:tests? #f ; no test suite
#:phases
(modify-phases %standard-phases
- (delete 'build)
- (add-before 'install 'set-perl-env
- (lambda* (#:key inputs #:allow-other-keys)
- (setenv "PERL5LIB"
- (string-append (assoc-ref inputs "perl-unicode-linebreak")
- "/lib/perl5/site_perl" ":"
- (getenv "PERL5LIB")))
- #t))
- (delete 'check))))
+ (delete 'build))))
(native-inputs
`(("asciidoc" ,asciidoc)
("gettext" ,gettext-minimal)
("git" ,git-minimal)
("perl" ,perl)
("perl-unicode-linebreak" ,perl-unicode-linebreak)
+ ("perl-yaml-tiny" ,perl-yaml-tiny)
("po4a" ,po4a)
("source-highlight" ,source-highlight)))
(home-page "https://kicad.org")
@@ -1233,14 +1227,14 @@ use on a given system.")
(define-public libredwg
(package
(name "libredwg")
- (version "0.12.3")
+ (version "0.12.4")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://gnu/libredwg/libredwg-"
version ".tar.xz"))
(sha256
- (base32 "1vhm3r3zr8hh0jbvv6qdykh1x14r4c1arl1qj48i4cx2dd3366mk"))))
+ (base32 "05v5k8fkx4z1p81x9kna7nlzmyx09dn686rj2zprnkf337qmg24i"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--disable-bindings")))
@@ -1303,6 +1297,36 @@ replacement for the OpenDWG libraries.")
(description "@code{minicom} is a serial terminal emulator.")
(license license:gpl2+)))
+(define-public sterm
+ (package
+ (name "sterm")
+ (version "20200306")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wentasah/sterm")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "031pd8yz2bfzqbari6za1c3xcqmw94ap4vbrjzb3v6izjcrca58c"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases (delete 'configure))))
+ (synopsis "Simple serial terminal")
+ (description "This is a minimalist terminal program like minicom or cu.
+The only thing it does is creating a bidirectional connection between
+stdin/stdout and a terminal device (e.g. serial line).
+It can also set serial line baudrate, manipulate DTR/RTS modem lines,
+send break and throttle transmission speed.")
+ (home-page "https://github.com/wentasah/sterm")
+ (license license:gpl3+)))
+
(define-public harminv
(package
(name "harminv")