summaryrefslogtreecommitdiff
path: root/gnu/packages/emulators.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-12-20 18:39:04 +0100
committerLudovic Courtès <ludo@gnu.org>2018-12-20 18:39:04 +0100
commit86974d8a9247cbeb938b5202f23ccca8d9ed627d (patch)
tree7bd498ccf672aced617aa24a830ec4164268c03f /gnu/packages/emulators.scm
parent03a45a40227d97ccafeb49c4eb0fc7539f4d2127 (diff)
parent9012d226fa46229a84e49a42c9b6d287105dfddf (diff)
downloadguix-patches-86974d8a9247cbeb938b5202f23ccca8d9ed627d.tar
guix-patches-86974d8a9247cbeb938b5202f23ccca8d9ed627d.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/emulators.scm')
-rw-r--r--gnu/packages/emulators.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 795595e447..991599a394 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -1186,7 +1186,7 @@ play them on systems for which they were never designed!")
(define-public mame
(package
(name "mame")
- (version "0.203")
+ (version "0.204")
(source
(origin
(method git-fetch)
@@ -1196,7 +1196,7 @@ play them on systems for which they were never designed!")
(file-name (git-file-name name version))
(sha256
(base32
- "19ccqc00024fbjyk0k5d9xljhwq7wsrp7phwm2jmn0h77mgdj844"))
+ "0yn63v2f1xlksfnvbxc5p5zpc7ps044m1kf69jhzbfirx953slsi"))
(modules '((guix build utils)))
(snippet
;; Remove bundled libraries.
@@ -1223,6 +1223,14 @@ play them on systems for which they were never designed!")
#:phases
(modify-phases %standard-phases
(delete 'configure)
+ ;; Prevent compilation error: ‘atan’ is not a member of ‘std’. Also
+ ;; fixed upstream in fec1cde5a40e197d4ed4314bf58b9e66e84e1631.
+ (add-after 'unpack 'fix-build
+ (lambda _
+ (substitute* "src/mame/video/xavix.cpp"
+ (("#include \"logmacro.h\"")
+ "#include \"logmacro.h\"\n#include <cmath>"))
+ #t))
(add-after 'build 'build-documentation
(lambda _ (invoke "make" "-C" "docs" "man" "info")))
(replace 'install