summaryrefslogtreecommitdiff
path: root/gnu/packages/embedded.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-12-11 22:18:05 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-12-11 22:18:05 +0100
commitb03e4fd5269897448124a7b61a737802b2c638ee (patch)
treee4eaab1d3076e335c57eea462ff7fda7919f0831 /gnu/packages/embedded.scm
parentda3c6a7f19ef1243af725f63c16c8fd92fde33b4 (diff)
parent99aad42138e0895df51e64e1261984f277952516 (diff)
downloadguix-patches-b03e4fd5269897448124a7b61a737802b2c638ee.tar
guix-patches-b03e4fd5269897448124a7b61a737802b2c638ee.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/embedded.scm')
-rw-r--r--gnu/packages/embedded.scm13
1 files changed, 4 insertions, 9 deletions
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 38c76cd737..f20d1e17c7 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -321,12 +321,6 @@ languages are C and C++.")
("pkg-config" ,pkg-config)))
(inputs
`(("libusb" ,libusb)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'autoreconf
- (lambda _
- (zero? (system* "autoreconf" "-vfi")))))))
(home-page "http://repo.or.cz/w/libjaylink.git")
(synopsis "Library to interface Segger J-Link devices")
(description "libjaylink is a shared library written in C to access
@@ -404,9 +398,9 @@ language.")
"presto" "openjtag")))
#:phases
(modify-phases %standard-phases
+ ;; Required because of patched sources.
(add-before 'configure 'autoreconf
- (lambda _
- (zero? (system* "autoreconf" "-vfi"))))
+ (lambda _ (invoke "autoreconf" "-vfi") #t))
(add-after 'autoreconf 'change-udev-group
(lambda _
(substitute* "contrib/60-openocd.rules"
@@ -417,7 +411,8 @@ language.")
(install-file "contrib/60-openocd.rules"
(string-append
(assoc-ref outputs "out")
- "/lib/udev/rules.d/")))))))
+ "/lib/udev/rules.d/"))
+ #t)))))
(home-page "http://openocd.org")
(synopsis "On-Chip Debugger")
(description "OpenOCD provides on-chip programming and debugging support