summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorDavid Thompson <davet@gnu.org>2016-05-31 15:25:10 -0400
committerDavid Thompson <davet@gnu.org>2016-06-03 08:54:25 -0400
commita2670dde107717a0f6298e9e6d125848cbdfbb57 (patch)
tree92837d5eaff342ba6266ec25af04fa4fdeab984c /gnu/packages/emacs.scm
parentb78b6e8040ed6666de07b8378bf364abb0046093 (diff)
downloadguix-patches-a2670dde107717a0f6298e9e6d125848cbdfbb57.tar
guix-patches-a2670dde107717a0f6298e9e6d125848cbdfbb57.tar.gz
gnu: Add emacs-projectile.
* gnu/packages/emacs.scm (emacs-projectile): New variable.
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index cd6438311b..1b54439bc7 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1861,3 +1861,29 @@ strings, and code folding.")
"Markdown-mode is a major mode for editing Markdown-formatted text files
in Emacs.")
(license license:gpl3+)))
+
+(define-public emacs-projectile
+ (package
+ (name "emacs-projectile")
+ (version "0.13.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://raw.githubusercontent.com/bbatsov"
+ "/projectile/v" version "/projectile.el"))
+ (file-name (string-append "projectile-" version ".el"))
+ (sha256
+ (base32
+ "1pc6xb61hzxzc5hkqkli1ab0s7wz0rfgx4kcn9y30ksvhw18smbz"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-pkg-info" ,emacs-pkg-info)))
+ (home-page "https://github.com/bbatsov/projectile")
+ (synopsis "Manage and navigate projects in Emacs easily")
+ (description
+ "This library provides easy project management and navigation. The
+concept of a project is pretty basic - just a folder containing special file.
+Currently git, mercurial and bazaar repos are considered projects by default.
+If you want to mark a folder manually as a project just create an empty
+.projectile file in it.")
+ (license license:gpl3+)))