summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2016-03-19 11:36:33 +0300
committerAlex Kost <alezost@gmail.com>2016-03-23 11:39:55 +0300
commit2382cb4f52b98e6bf28d388194ab0100ef9f23c9 (patch)
tree6f7971be96851059c9d408e14ac7164c27231567 /gnu/packages/emacs.scm
parent8c9ec2038642f075b3741816bb89c8365edd230c (diff)
downloadguix-patches-2382cb4f52b98e6bf28d388194ab0100ef9f23c9.tar
guix-patches-2382cb4f52b98e6bf28d388194ab0100ef9f23c9.tar.gz
gnu: texinfo: Use version 6.1 by default.
* gnu/packages/texinfo.scm (texinfo): Update to 6.1. (texinfo-6.1): Remove. * gnu/packages/emacs.scm (emacs)[arguments]: Remove 'remove-info.info' phase.
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm8
1 files changed, 0 insertions, 8 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index f53f73bb8a..215061a67a 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -88,14 +88,6 @@
(substitute* (find-files "." "^Makefile\\.in$")
(("/bin/pwd")
"pwd"))))
- (add-after 'install 'remove-info.info
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Remove 'info.info', which is provided by Texinfo <= 6.0.
- ;; TODO: Remove this phase when we switch to Texinfo 6.1.
- (let ((out (assoc-ref outputs "out")))
- (delete-file
- (string-append out "/share/info/info.info.gz"))
- #t)))
(add-after 'install 'install-site-start
;; Copy guix-emacs.el from Guix and add it to site-start.el. This
;; way, Emacs packages provided by Guix and installed in